I've uninstalled Razer Synapse however the menu bar icon is still remaining on my computer. This is a common issue on google but everything I've tried doesn't work.

Things I've tried:

  1. Delete razer synapse from Applications, /Library/StartupItems /Library/LaunchDaemons and /Library/LaunchAgents. Also checked /System/Library/
  2. Use the razer synapse uninstaller. It said it's damaged
  3. Go to /Library/ search the term Razer and delete everything that showed up
  4. Reinstall razer synapse to get the uninstaller to work. It still didn't work

I'm very confused why this has to be so difficult. If anyone has any ideas I would love to hear them.

  • Instead of simply deleting the folder(s), use a Utility like AppCleaner that will remove helper files as well.
    – Allan
    Jul 14 at 20:47

2 Answers 2


/Library/StartupItems /Library/LaunchDaemons and /Library/LaunchAgents.

You need to check the user domain ~/Library subfolders, as well as the ones in /Library.

Also see if Razer has a subfolder in Application Support (sub-folder of /Library and ~/Library.)

Most importantly, you need to contact the developers of the app, and ask them why their uninstaller doesn't work.

Personally, I'd stay away from 'cleaner' apps, as they can delete the wrong thing or miss the right thing just as easily as you can; and they frequently have a poor reputation.


First reinstall Razer Synapse. Then download AppCleaner and drag and drop the application in and hit remove. After it uninstalls, reboot.

If you continue to have problems, open ~/Library from the terminal and search in there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .