2

I have three different physical USB-C Lan "dongles".

  • Belkin USB-C to Gigabit Ethernet Adapter (USB Type-C) F2CU40 (White)
  • Belkin USB-C to Gigabit Ethernet Adapter (USB Type-C) F2CU40 (Black)
  • iHome 3-Inch USB Type-C Ethernet Adapter

I have an ethernet cable connected directly from my ISP's modem to the dongle and my mac.

For some strange reason only the Black Belkin dongle connects and works automatically. When I swap it out and try a different one I get the following message:

Belkin USB-C LAN has a self-assigned IP address and will not be able to connect to the Internet.

I've tried both of the following with a different dongle plugged in.

  1. Power cycling the ISP's modem
  2. Using the ISP's app to "Restart" the modem's signal

This post is similar to this other question, which doesn't have a clear resolution.

Apple USB Ethernet Adapter has a self-assigned IP address and will not be able to connect to the Internet

Is it simply that these other dongles don't work?

6
  • 2
    There could be a potential issue with the DHCP server (embedded) in the ISP’s router. I would try connecting those ethernets to a different router and see if the problem still exists.
    – Allan
    Jul 5, 2023 at 15:27
  • 1
    Have you tried restarting the Mac between dongle swaps?
    – IconDaemon
    Jul 5, 2023 at 16:32
  • 2
    I’ve seen a router that “remembered” the last MAC address and wouldn’t connect to anything else. Do what @Allan said and try on a different network. That router had to be reset by the ISP to work with a different adapter. Jul 5, 2023 at 17:51
  • @IconDaemon I restarted my mac with the white dongle and still no change. I also have a totally different mac (2 total macbook airs) that work with the same black belkin dongle. I think it has something to do with my ISP only knows the mac address of that dongle and won't register any other IP addresses to any others. I have a technician coming tomorrow to swap out the ISP's modem / router will update this thread. Jul 5, 2023 at 17:53
  • 2
    Ask a tech at work or a friend/neighbors house. It’s a USB adapter so it will work with pretty much all modern computers (Windows and macOS). If it works there, you know it’s not the adapter. I know that macOS doesn’t do anything special with the network stack so as long as it gets recognized, it’ll get an IP. The best thing to do is get a hardware based firewall and put that between your ISP box and your computers.
    – Allan
    Jul 5, 2023 at 18:05

1 Answer 1

1

It turns out that there was an issue with my Internet Service Provider's (ISP) router/modem: it was unable to assign new IP addresses. Oddly enough, it only recognized the MAC address of one functioning USB-C dongle. When this dongle was replaced, the others didn't work simply by swapping them out. I suspect this is because my ISP only allocates one IP address to me. Consequently, if I'm dividing the hardline with a standard Ethernet switch or just exchanging dongles, it won't function without resetting the modem. Upon reboot, the modem assigns an IP address to one of the MAC addresses. To overcome this problem, I had to use a Wi-Fi router to split the signal and assign new internal IP addresses.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .