1

There are related questions here, but many are dated and none seems to quite cover my situation.

I have an early 2015 MacBook Pro that has been kept as up to date as possible, currently running 12.6.7. The file system is case sensitive. I have always used Time Machine to back it up; apparently TM always uses case sensitive file system.

The 2015 machine is dying due to an expanding battery. So, I have a new MacBook Pro. I fired it up, plugged in the TM drive and it complained that the new machine was case insensitive but the backup was case sensitive. Fine. Launched the new machine into recovery mode, erased the drive and reformatted as case sensitive. Then installed Ventura, which apparently converted the drive to case insensitive, as trying to use the TM backup gave the same error.

The old machine shows the following:

~> diskutil list
/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.3 GB   disk0
   1:                        EFI ⁨EFI⁩                     209.7 MB   disk0s1
   2:                 Apple_APFS ⁨Container disk1⁩         500.1 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +500.1 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume ⁨Untitled - Data⁩         411.8 GB   disk1s1
   2:                APFS Volume ⁨Preboot⁩                 612.1 MB   disk1s2
   3:                APFS Volume ⁨Recovery⁩                1.1 GB     disk1s3
   4:                APFS Volume ⁨VM⁩                      1.1 GB     disk1s4
   5:                APFS Volume ⁨BryanHD⁩                 15.4 GB    disk1s5
   6:              APFS Snapshot ⁨com.apple.os.update-...⁩ 15.4 GB    disk1s5s1

and the details for the relevant data volume:

~> diskutil info disk1s1
   Device Identifier:         disk1s1
   Device Node:               /dev/disk1s1
   Whole:                     No
   Part of Whole:             disk1

   Volume Name:               Untitled - Data
   Mounted:                   Yes
   Mount Point:               /System/Volumes/Data

   Partition Type:            41504653-0000-11AA-AA11-00306543ECAC
   File System Personality:   Case-sensitive APFS
   Type (Bundle):             apfs
   Name (User Visible):       APFS (Case-sensitive)
   Owners:                    Enabled

   OS Can Be Installed:       Yes
   Booter Disk:               disk1s2
   Recovery Disk:             disk1s3
   Media Type:                Generic
   Protocol:                  PCI
   SMART Status:              Verified
   Volume UUID:               48C0C04E-5D1C-3FA9-9339-93B1BD12E05A
   Disk / Partition UUID:     48C0C04E-5D1C-3FA9-9339-93B1BD12E05A

   Disk Size:                 500.1 GB (500068036608 Bytes) (exactly 976695384 512-Byte-Units)
   Device Block Size:         4096 Bytes

   Container Total Space:     500.1 GB (500068036608 Bytes) (exactly 976695384 512-Byte-Units)
   Container Free Space:      70.3 GB (70319427584 Bytes) (exactly 137342632 512-Byte-Units)
   Allocation Block Size:     4096 Bytes

   Media OS Use Only:         No
   Media Read-Only:           No
   Volume Read-Only:          No

   Device Location:           Internal
   Removable Media:           Fixed

   Solid State:               Yes
   Hardware AES Support:      No

   This disk is an APFS Volume.  APFS Information:
   APFS Container:            disk1
   APFS Physical Store:       disk0s2
   Fusion Drive:              No
   APFS Volume Group:         48C0C04E-5D1C-3FA9-9339-93B1BD12E05A
   Encrypted:                 No
   FileVault:                 No
   Sealed:                    No
   Locked:                    No

   APFS Snapshots are defined upon this APFS Volume.  Snapshot list:
   Snapshot UUID:             7EB6E3E4-2450-4FD9-8D86-B698FC2AAADB
   Name:                      com.apple.TimeMachine.2023-07-03-151546.local
   XID:                       1595566
   Snapshot UUID:             AD44753D-4F92-4295-99AC-F641395D46DB
   Name:                      com.apple.TimeMachine.2023-07-03-152211.local
[ other snapshots deleted for space ]

This info seems reasonable, it's the modern APFS system and case sensitive as I expected.

Now, on the new machine, boot into recovery mode, erase and format to AFPS (Case-sensitive), restart, activate mac, reboots back into recovery mode, reinstall macOS Ventura, answer the questions, skipping anything I can, then

diskutil info disk3s1

and see that its name is "Untitled - Data" and it is formatted case insensitive!

I tried to reformat via

diskutil eraseVolume APFSX "Untitled - Data" disk3s1

but this fails because launchd is running on this volume.

Looking for help getting this TM backup onto the new machine in a case sensitive manner.

7
  • 2
    Time Capsules used case-sensitive for some unknown reason. The Mac itself doesn't. In fact case sensitive on Mac has always generally been a bad idea. Also this. Unless you're certain you need it… you don't. You can recover from case sensitive to insensitive [unless you actually have 2 files of the same name in the same place] but I'd be inclined to start over on a new TM drive.
    – Tetsujin
    Commented Jul 4, 2023 at 17:03
  • I do need a case-sensitive file system (I know this topic is extensively litigated on SO), I need my current TM drive to move all my work to the new computer, I'm not sure what you mean by "start over". Commented Jul 4, 2023 at 18:12
  • I regularly recover files from my TM backup to the main computer, so I guess TM backup process knows how to deal with this issue. Apparently it's Migration Assistant or a similar surrogate that doesn't know what to do. Commented Jul 4, 2023 at 19:05
  • Well, recovering a backup in the case of the original computer would be case-sensitive to case-sensitive, so that proves nothing I guess. Commented Jul 4, 2023 at 19:41
  • @BryanHanson Why do you need a case-sensitive filesystem on your Mac? Commented Jul 4, 2023 at 21:26

1 Answer 1

0

If you have a case-sensitive backup disk and a case-insensitive Mac, you can convert your Mac to be case-sensitive before restoring the backup disk.

To convert it, I believe you will have to create a new Volume in Disk Utility formatted as APFS (Case-sensitive) and install macOS onto that Volume. You can create the Volume and install macOS from the Recovery mode directly onto the new Volume. Follow the instructions here after you create the new Volume. You can delete the original Volume at this time too if there is no data on it.

During the setup process on the new Volume you can run Migration Assistant.

4
  • Thank you. This sounds exactly like what I described doing in the original question... when reinstalling macOS it converts the case-sensitive volume back to case-insensitive. Perhaps there is some small detail I am missing. Commented Jul 5, 2023 at 13:59
  • Ah, yeah that's my mistake - I've not completed this process. Reading around, it seems like macOS will always convert the volume to case-insensitive on install, and time machine always uses case-sensitive. However, this should not be an issue since a case-insensitive origin backing up to a case-sensitive one should not cause conflicts on restore.
    – Ezekiel
    Commented Jul 5, 2023 at 14:02
  • However in this case, since your origin is case-sensitive that causes more issues.
    – Ezekiel
    Commented Jul 5, 2023 at 14:02
  • This is certainly tricky, and hard/time consuming to test. Thanks for your input. I'm still thinking about alternatives. Commented Jul 5, 2023 at 14:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .