1

Recently acquired an old MacBook Pro, new to MacOS.

I have downloaded & installed node 16.20.1 https://nodejs.org/en/download/releases

npm install fails. npm doctor returns:

Check                               Value   Recommendation/Notes
npm ping                            not ok  error:0909006C:PEM routines:get_name:no start line
npm -v                              not ok  Error: error:0909006C:PEM routines:get_name:no start line
node -v                             not ok  Error: error:0909006C:PEM routines:get_name:no start line
npm config get registry             ok      using default registry (https://registry.npmjs.org/)
which git                           ok      /usr/local/bin/git
Perms check on cached files         ok
Perms check on local node_modules   ok
Perms check on global node_modules  ok
Perms check on local bin folder     ok
Perms check on global bin folder    ok
Verify cache contents               ok      verified 0 tarballs
npm ERR! Some problems found. See above for recommendations.

npm ERR! A complete log of this run can be found in:
npm ERR!     /Users/travis/.npm/_logs/2023-06-26T21_56_49_431Z-debug-0.log


logfile contents:


0 verbose cli /usr/local/bin/node /usr/local/bin/npm
1 info using [email protected]
2 info using [email protected]
3 timing npm:load:whichnode Completed in 1ms
4 timing config:load:defaults Completed in 2ms
5 timing config:load:file:/usr/local/lib/node_modules/npm/npmrc Completed in 1ms
6 timing config:load:builtin Completed in 1ms
7 timing config:load:cli Completed in 2ms
8 timing config:load:env Completed in 0ms
9 timing config:load:project Completed in 12ms
10 timing config:load:file:/Users/travis/.npmrc Completed in 3ms
11 timing config:load:user Completed in 3ms
12 timing config:load:file:/usr/local/etc/npmrc Completed in 0ms
13 timing config:load:global Completed in 0ms
14 timing config:load:validate Completed in 3ms
15 timing config:load:credentials Completed in 1ms
16 timing config:load:setEnvs Completed in 2ms
17 timing config:load Completed in 26ms
18 timing npm:load:configload Completed in 26ms
19 timing npm:load:mkdirpcache Completed in 2ms
20 timing npm:load:mkdirplogs Completed in 1ms
21 verbose title npm doctor
22 verbose argv "doctor"
23 timing npm:load:setTitle Completed in 28ms
24 timing config:load:flatten Completed in 4ms
25 timing npm:load:display Completed in 6ms
26 verbose logfile logs-max:10 dir:/Users/travis/.npm/_logs
27 verbose logfile /Users/travis/.npm/_logs/2023-06-26T21_56_49_431Z-debug-0.log
28 timing npm:load:logFile Completed in 7ms
29 timing npm:load:timers Completed in 0ms
30 timing npm:load:configScope Completed in 0ms
31 timing npm:load Completed in 72ms
32 info Running checkup
33 silly logfile start cleaning logs, removing 1 files
34 silly logfile done cleaning log files
35 timing command:doctor Completed in 140501ms
36 verbose stack Error: Some problems found. See above for recommendations.
36 verbose stack     at Doctor.exec (/usr/local/lib/node_modules/npm/lib/commands/doctor.js:126:13)
36 verbose stack     at async module.exports (/usr/local/lib/node_modules/npm/lib/cli.js:78:5)
37 verbose cwd /Users/travis
38 verbose Darwin 17.7.0
39 verbose node v16.20.0
40 verbose npm  v8.19.4
41 error Some problems found. See above for recommendations.
42 verbose exit 1
43 timing npm Completed in 140587ms
44 verbose code 1
45 error A complete log of this run can be found in:
45 error     /Users/travis/.npm/_logs/2023-06-26T21_56_49_431Z-debug-0.log
  • I have tried manually installing & uninstalling node & npm
  • I have tried installing node via nvm
  • I am not able to install node via homebrew due to gcc dependency (willing to try if someone can walk me through installing a package outside homebrew then linking to homebrew)
  • I have tried setting <npm config set registry=http://registry.nmpjs.org/. and back

Is there an SSL certificate I need to add or modify somewhere? What else can I look at to troubleshoot this?

1 Answer 1

0

Solved, in short: Was a cryptography problem, not node/npm problem

In detail: -Uninstalled node/nvm -Found MacPorts support for nodejs17 -returned error:1E08010C:DECODER routines::unsupported on that install pointing to cryptography rather than node -uninstalled all node dependencies from Homebrew -reinstalled those via MacPorts -installed nvm via MacPorts -installed node 16 LTS Gallium via nvm

Working!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .