0

I used the exit command once in terminal and it gave me the following message:

Last login: Tue Jun 20 09:18:45 on ttys005

Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.

[Process completed]

Now every time I try to open a new window/tab it displays the same message and does not allow me to type anything else into the shell. It seems that the exit command is being run automatically on login. How do I fix this?

1
  • Are you using zsh or bash?
    – nohillside
    Jun 21, 2023 at 5:16

1 Answer 1

1

Remove the directory ~/.zsh-sessions.

You can then disable the ZSH session nonsense by setting SHELL_SESSIONS_DISABLE=1 in ~/.zshenv.

1
  • 3
    Why would a saved session lead to a blocked shell on reload?
    – nohillside
    Jun 20, 2023 at 20:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .