0

Ever since Dropbox updated its software a few months ago, and advised all Mac users to update in order to continue having the same facilities, a folder in my Dropbox Cloud was apparently corrupted and could not be read. I tried to salvage what I could and deleted the folder directly from the Dropbox site. It, however, appears in my Trash and cannot be deleted. I get: "The operation can't be completed because the item <> is in use". (All other items do get deleted from Trash.) I have tried sudo rm commands from Terminal, using all possible parameters (-R, -ri, -rf etc.) to no avail. I have tried to erase it before Dropbox gets loaded at startup, again to no avail. I have erased ".Trash", but again the stubborn file pops up in the Trash. I am using MacOS Monterey 12.6.6 on a Mac Pro (Late 2013). Help will be much appreciated. Thanks.

3
  • Did you try sudo fs_usage | grep [path_to_folder] in order to ensure that Dropbox is the only process which is using the folder ? It could be another process. Alternatively did you try rebooting in safe mode to make the operation of emptying the trash ? Jun 19, 2023 at 2:40
  • Thanks for your prompt answer. Rebooting in safe mode did not help. I have just tried your sudo fs_usage suggestion and I get the following response that I cannot understand: 20:46:25 getattrlist /Users/enahmad/Library/CloudStorage/Dropbox/.Trash/España 0.000018 fileprovider 20:46:25 open /Users/enahmad/Library/CloudStorage/Dropbox/.Trash/España 0.000034 fileprovider 20:46:25 openat [-2]//Users/enahmad/Library/CloudStorage/Dropbox/.Trash/España 0.000011 fileprovider What should I do?
    – eduardo
    Jun 19, 2023 at 2:49
  • with that response you can know fileprovider is a process that uses some files inside .Trash. Perhaps trying to force quit these processes would help. But this process is a system process, that is probably launched by a master process Jun 19, 2023 at 2:57

1 Answer 1

1

I had a similar problem.  The solution was to move the item to /tmp and reboot.  (Reboot deletes everything in /tmp)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .