As seen on the screenshot, I want to only leave the custom layout for English by deleting ABC. But the "–" is blocked off. How do I delete it with SUDO-actions?

Note: I'm on Catalina 10.15.7.

1 Answer 1


Actually, macOS needs at least 1 keyboard layout to be a Latin keyboard; so it's not possible to delete it in System Settings. You might be able to change the other keyboards to make macOS recognise it as a Latin one but I'm not sure it will work and if you mess up the system. If you really want to remove it then I found another post that's similar to yours but it's a bit outdated. It should help, it's linked below.

How to remove or disable a default keyboard layout?


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .