2

How can I disable auto-lock in the 1Password browser extension?

I use the 1Password password manager and the Chrome web browser. Whenever I try to auto-fill a password, a tool tip says, "Press the 1Password icon in your browser's toolbar to unlock." When I click the icon in the toolbar, it prompts me to enter my password.

In the 1Password app, I navigated to 1Password menu –> Preferences... –> Security. I set, "Require Master Password every 2 weeks," and I disabled all five kinds of auto-lock. In the 1Password browser extension, I navigated to Menu –> Settings... –> Security, and I disabled, "Automatically lock 1Password." Nevertheless, the browser extension continues to repeatedly ask for my password.

I searched on the 1Password website, and I read the support article, "How to set 1Password to lock automatically." I also read the Reddit post "How to disable 1Password X lock?" Unfortunately, this post comes from three years ago, and it refers to 1Password X, but I use 1Password 7 instead. According to 1PasswordCS-Blake, for 1Password X, the extension does not integrate with the app. But for 1Password 7, the settings for the extension show a toggle switch for integrating with the app.

Please find attached screenshots of the tool tip in the browser extension, password prompt in the browser extension, security preferences in the app, and security settings in the browser extension.

Figure 1: Tooltip in Browser Extension Tooltip in Browser Extension

Figure 2: Password Prompt in Browser Extension Password Prompt in Browser Extension

Figure 3: Security Preferences in App Security Preferences App

Figure 4: Security Preferences in Browser Extension Security Settings in Browser Extension

10
  • 2
    Does it still auto-fill passwords on entering a new site? I'm not sure this isn't expected behaviour. Both Safari & the Apple keychain also exhibit this behaviour - auto-fill works, but if you actually want to visually inspect a saved password field, you must authenticate each & every time.
    – Tetsujin
    Jun 7, 2023 at 17:09
  • 1
    @Tetsujin No, the browser extension does not auto-fill passwords when it is locked. Instead it displays a tool tip which says, "Press the 1Password icon in your browser's toolbar to unlock." I edited the question to attach a screenshot of this. Jun 7, 2023 at 21:10
  • 1
    Shouldn't you unlock from extension itself? Click on extension icon on Safari window bar (or wherever it's placed) and unlock from there. It should stay unlocked. You can also access extension settings and check whether everything seems ok. Jun 8, 2023 at 5:53
  • 1
    I can't reproduce your issue on Safari and don't have chrome. I wonder what would happen if you enabled the idle sleep and set it for something like 15 or 30 minutes, then restarted the computer, unlocked the app and then retested? Sometimes you need to make a concrete write to the preferences. I would also ask 1Password support - they are very good.
    – bmike
    Jun 8, 2023 at 15:10
  • 1
    It’s the lock after computer is idle for 5 minutes in Figure 3. It’s inactive above. Make it active then save and restart
    – bmike
    Jun 9, 2023 at 11:00

1 Answer 1

1

I don't have a copy of 1Password 7 available, but it may be similar to this issue for 1Password 8:

Solution for 1Password locking itself constantly despite auto-lock settings disabled

In 1Password 8, the workaround is to enable the menu bar item under Settings > General > Keep 1Password in the menu bar. Then the auto-lock settings under Security will be respected. Otherwise, every time the app window is closed the browser extension will be locked.

1
  • Thank you for your suggestion. I already had enabled "Keep 1Password in menu bar." 1Password is still auto-locking. But I'm using my fingerprint to unlock instead of a password. This is quite convenient. So I hardly mind the auto-lock anymore. Oct 12, 2023 at 17:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .