I'm using Google calendar, and I subscribe to my Google Calendar from multiple computers. Whenever I set an event with (an) email reminder(s) on Google calendar, I'll get multiple emails because (1) Google calendar itself sends me the email reminder and (2) each computer that subscribes the calendar tries to send the email reminder (when the computer wakes up). It's very annoying.

  • What version of the operating system are you running?
    – Daniel
    Mar 26, 2012 at 15:36
  • 1
    This should be considered a bug - I can't imagine thinking it is working as intended. Yet here we are, over a decade later...
    – WillyC
    May 27, 2021 at 22:39

4 Answers 4


For Mac OS X Mountain Lion 10.8.0:

  1. Click on the "Calendars" button on the main window to show the sidebar of calendars.
  2. Right mouse click on the calendar you want to ignore alerts from & choose "Get Info"
  3. Check ON "Ignore Alerts" & click "OK"

Seems as thought you don't have to globally set this preference, you can now selectively choose which calendars have alerts or not, through iCal.

  • 19
    This turns off everything, right? Not just email notification, but also the notification center pop-ups.
    – jhfrontz
    Jun 30, 2015 at 13:45

You can disable all alerts, including email alerts, in ical via

iCal --> Preferences --> Advanced --> Turn off all alarms

If you need to have iCal display alarms on the mac, but simply not send the email, then you will need to turn to other software. Here are two applications that help tame iCal notifications:


  • This should allow you to define what emails get sent. It's primary use is taming meeting schedule notifications that iCal sends when you schedule a meeting with multiple participants, but it looks like it can be used to better configure what emails iCal sends


  • This tracks your calendars (iCal, or google directly) and use growl to alert you for upcoming events. Use this if you want to disable emails by disabling all iCal alerts, and then setting this up to receive the alerts on the mac that you want to receive onscreen.
  • +1 for CalendarBar, I use it all the time and its awesome!
    – binarybob
    Mar 26, 2012 at 15:55
  • 4
    "iCal --> Preferences --> Advanced --> Turn off all alarms" is not available on Mac OS X 10.8 as far as I can tell.
    – pauldoo
    Mar 12, 2013 at 21:18
  • Dammit... Clean Cut Code has closed down and discontinued CalendarBar Aug 22, 2013 at 18:28
  • @pauldoo: ...and the option did not come back in OS X 10.9 "Mavericks" either. Which is a real pity. Jul 16, 2014 at 12:29
  • Also not in MacOs 12.12 "Sierra" either.
    – Matt
    Jan 12, 2017 at 16:47

I created a filter in gmail to delete these alert emails.

It's not a perfect solution, but I do want to be able to receive alerts in iCal, and I want to receive email alerts from Google Calendar as well. This meets both of those requirements, but it's definitely a workaround.


as far as i understand iCal it is on the "receivers/subscribers" side to deal with email-updates (and not on the "senders/changers" side) ...

to NOT get email notification about updated events from a shared calendar you subscribed to you have to uncheck "events affect availability" in that calendars "info" (mac os X.7 and X.8: iCal —> calendars dropdown —> right click on the subscribed calendar —> choose "get info" from the context-menu —> uncheck "events affect availability")

this availability-logic kind of makes sense once you think about it ... problem is: "events affect availability" is checked by default for any newly subscribed shared calendar

here is a screenshot of the calendar-info-window: https://discussions.apple.com/message/20506464#20506464

  • 1
    this seems to work, but the problem is that the setting is reset every so often. I uncheck it, then some time later it is checked again so I get email again. Do you know how to prevent it from re-checking ? Jun 15, 2018 at 15:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .