0

I have restarted the computer.

I have tried the accepted solution to this similar question from over a decade ago.

But macOS keeps behaving poorly.

How to I get macOS to stop asking this every time I lauch the app?

2 Answers 2

3

It turns out that I needed to launch LibreOffice by clicking its icon (which I rarely do), rather than launching it by opening a document such as an .odt, .docx, .ods, or .xlsx file (which I do all the time).

Once I launched it (from the Dock icon) macOS was able to register my permission for the app permanently.

0

For me, neither starting the application from the Dock nor the accepted answer in 'Excessive "Opening application for the first time" dialogs' helped. However, wisbucky's answer over there worked for me.

So I had to remove the application from quarantine manually like so:

xattr -d com.apple.quarantine /Applications/LibreOffice.app/

This problem started once I stopped manually downloading LibreOffice for updates and switched to updating it via Homebrew. I wonder if there's some issue with the formula which needs to be reported.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .