3

I've been experimenting with external display on my MacBook Air. I had the external display set up as a primary monitor and my Mac's built-in display as a secondary. Then for some unknown reason the external monitor stopped working. It just sits there saying "no signal" but my Mac display stays as a secondary screen. In this case I can't do anything as all the windows remain in the external monitor that is not showing.

When I unplug the external monitor the Display settings change, so I can't revert anything:

enter image description here

So my question - where do they store current display settings? Or, how do I reset them to their defaults?

(I just want to say that this is such a stupid UI if someone has to ask this on a public forum.)

14
  • 1
    I’m unclear about your last sentence: when you unplug the monitor, the settings change so you can’t revert. How do they change exactly? What are you trying to revert to?
    – Allan
    May 22, 2023 at 17:33
  • 1
    I have no way to test this, but I have a hunch it may be part of 'Displays have separate Spaces'. Disabling that might jump the 'missing' windows back into view. [Used to need a reboot] I don't have a dual display Mac running Ventura, so I can't even really look at the possible options.
    – Tetsujin
    May 22, 2023 at 17:54
  • 1
    Yeah, I've seen how they've totally messed it all up ;) I have one Ventura Mac here, just no option to add a second display to try look at any of this multi-screen stuff.
    – Tetsujin
    May 22, 2023 at 18:01
  • 1
    It’s not a refresh rate, but a clock sync issue. An active adapter will likely fix your issue. See this similar question/answer about the screen staying blank. Sometimes a restart of the Mac will fix it, other times you have to power cycle the monitor as well. See if that fixes the issue. That said, there’s noting in settings to fix this problem (clock sync)
    – Allan
    May 22, 2023 at 18:11
  • 1
    I just realised display settings are in NVRAM… wonder if blowing that at boot might work?? Assuming you're on an Intel, Cmd/Opt/P/R at the chimes then wait until you hear the chimes again. [If it's Apple silicon, I've no idea, sorry]
    – Tetsujin
    May 23, 2023 at 8:12

4 Answers 4

2

After some messing around (to overcome the bad UI) I was able to reset it and see why it didn't work. A couple of pointers:

  1. Never ever set the built-in display to anything other than the "main display"!

enter image description here

Otherwise you will screw yourself over if the external display doesn't connect and it is set as the main display.

  1. If you manage to screw yourself out of seeing the main screen, click the Apple logo on the top left corner of the screen that you can see, and pick "System settings". This (hopefully) will open the setting screen in the MacBook's screen, then go to Displays and revert the MacBook's built-in display to the "main display" status (as I showed above.) This way at least you will be able to start an app and see what you're doing. (Apple's bad UI expects everything to happen in the main display, and if you can't see it ... well, you're screwed.)

  2. Finally, the reason why my external monitor didn't work is because the refresh rate was set to something that it didn't support. For me tweaking it down to 24 Hz worked:

enter image description here

As to why it worked and then stopped working ... I have no idea.

3
  • Glad that worked for you. But it doesn't really answer your original question : "How to reset display settings on macOS Ventura to their defaults?"
    – Thinkr
    May 28, 2023 at 12:26
  • @Thinkr it doesn't, you're right. But it may help someone if they get themselves into a similar situation. Otherwise I am somewhat leery about messing with the NVRAM like someone suggested in the comments. It may be the answer.
    – c00000fd
    May 28, 2023 at 12:29
  • Yeah, might be beneficial to include that in the answer ;)
    – Thinkr
    May 28, 2023 at 12:30
1

The problem you have described seems to be about the same as the one described in If there’s no picture on your Mac after you change the resolution - Apple Support. According to the same article, to reset this parameter, you can :

Reset the resolution automatically

  1. Wait 15 seconds to see if your Mac resets the display resolution on its own.
  2. If the display resolution doesn’t reset on its own, press Esc (Escape) to revert your display to the previously selected resolution.

Or

Reset the resolution in safe mode

If you can’t reset your display’s resolution automatically, you can restart your Mac in safe mode and choose another resolution.

  1. Start up your Mac in safe mode. Startup may take a bit longer than usual, but your display should begin working correctly.
  2. After your Mac starts up, choose Apple menu > System Settings, then click Displays in the sidebar. (You may need to scroll down.)
  3. Click Default on the right to use the best resolution for your display.
  4. Restart your Mac normally.
8
  • Hitting escape doesn't do anything. I haven't tried rebooting in safe mode though.
    – c00000fd
    May 22, 2023 at 17:52
  • @c00000fd I wasn't able to replicate your issue so I couldn't test it out. But that's what is said in the Apple documentation so it can but be right. Come back to me if you decide to try in safe mode.
    – Thinkr
    May 22, 2023 at 18:00
  • 1
    Yeah, I appreciate it. If I get to the bottom of it, I'll post an update.
    – c00000fd
    May 22, 2023 at 18:06
  • 1
    @c00000fd Okay, I'll be there if you need further help or clarification, don't hesitate to ask ;)
    – Thinkr
    May 22, 2023 at 18:09
  • I got distracted by something else. I'll post an update when I get to it.
    – c00000fd
    May 27, 2023 at 15:33
1

I had this problem today as well and was very frustrated by it for several hours. One person suggested a solution where you use TeamViewer to log into the Mac and remotely change the settings while the clamshell to the MacBook is closed and connected to the blanking monitor, but I couldn't get that to work either.

Finally I found a reasonably simple solution that works through the command line terminal here: https://superuser.com/questions/165108/misconfigured-external-monitor-on-mac-os-x-snow-leopard-10-6-3

What you do is delete the following files:

/Library/Preferences/com.apple.windowserver.plist

And remove every file named:

/Library/Preferences/ByHost/com.apple.windowserver.*.plist

You will likely have to sudo as root: sudo rm {filename}

Then reboot your Mac and monitor settings should return to defaults.

I hope this helps someone solve this problem quicker than I did!

0

SOLVED: This issue is a result of accidentally setting your monitor as your main display, and due to Apple's poor UI, you can only change display settings of your monitor when it's plugged in. This also due to a resolution discrepancy between your main-display and your monitor.

I tried everything to fix this issue, even brought it to the apple store and they were no help. I tried using terminal along with the different restart methods, but this is the best way to fix (It was briefly mentioned in a previous response):

  1. You will need a second laptop/desktop. Can be yours or your friends, they can even help you from their house. Do not plug in the monitor until Step 6.

  2. Download TeamViewer (this is not an Ad) on the first device and the second device, it is free, it is trusted, and easy to install/uninstall. You only need to create an account on the second device, again it's free. This will allow the second device to control the screen displayed on the monitor while it's plugged in despite no signal.

  3. Open TeamViewer and create an account on the second device, no need to create one on the first device. Once the account is created, start a session using the second device.

  4. Open TeamViewer on the first device, and using the session code created by the second device, join the session. Give TeamViewer permission to access your device. Once permission is granted, the second device will be able to control the cursor on the first device.

  5. Open up System Preferences > Displays.

  6. Plug in the monitor and wait for the display to change. You should then be able to control the monitor screen from your second device. In Display > Display Settings, set your first device to Main Display and your monitor to Extended Display.

  7. Finally, find your monitor's display resolution, in my case it was 1920x1080. Then in display settings, under resolution (For your monitor, not your Main-display) select 'Scaled'. Select the correct resolution for your monitor. This should fix the issue.

  8. I would keep TeamViewer running and installed until you have definitely fixed the issue. Once fixed, uninstall TeamViewer if you'd like. Apple Logo > About this Mac > Storage > Manage... > Applications > Delete.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .