1

my MB is a few months old and I dont know if the trackpad is starting to misbehave just now or it's been like this the whole time and I just didnt notice.

Problem description:

The trackpad is set to right-click ("Secondary Click") in bottom-right corner, but sometime it does not work. I cant tell the exact sequence of events when that happens, because I use it without thinking about every move or click and I realize it doesnt work only when it actually doesnt work.

Below is the most deterministic way how I am able reproduce it (but this is not what my normal workflow is - again just the way I am able to reproduce it, so please dont comment like "bUt WhY aRe yOu dOiNg tHiS?")

  • in System Settings set "Secondary Click" (aka Right Click) into right-bottom corner
  • click in right-bottom corner and keep holding
  • (while holding) drag finger towards the bottom-center of trackpad and back to the bottom-right corner where you started from
  • release finger
  • click trackpad again. Since your finger is in the bottom-right corner, it should do Secondary Click, but it doesn't.
  • keep clicking repeatedly but still no Secondary Click unless some yet unknown condition occurs and Secondary Click starts working again.

Note that this doesnt work 100% of time, but it's the scenario where I can reproduce it most of the times.

  • no external mouse is connected
  • same behaviour when i set Secondary Click to bottom-left corner

So my question is - can someone reproduce this behaviour with their machine as well (or just mine so I should most likely go to service with it)? If yes, is there any setting I can change to disable this behaviour?

MacBook Pro M2, 14", Ventura 13.4 (same behaviour on 13.3)

1
  • Questions asking whether others can reproduce a problem don’t work very well in a Q&A setting. Please focus the question on the problem to be solved.
    – nohillside
    Commented Dec 27, 2023 at 7:12

3 Answers 3

5

I found this post when I was experiencing this same issue and was looking to see what the internet had to say, but I've figured it out for my machine since.

Basically, the right-click started working normally once I disabled the "Zoom in or out / Pinch with two fingers" option under the trackpad Scroll & Zoom settings. (Thanks to this post for pointing out the weird dragging-down behavior.)

My guess is that the new machine either has broader gesture recognition than the old one, or that unlike the old one it ignores the right-click if it recognizes another gesture. Either way, I'm disabling the other two-finger gestures to be safe. And if it still acts up, do a zoom-in motion, then right-click with only one finger.

2

I can reproduce exactly the same behavior on one of my notebooks. I have a new Macbook Pro M3 14" and an older M1 14". The M1 works as expected, while the M3 has the sporadic dropouts when right-clicking. Both devices have exactly the same configuration, the same software and the same settings for the trackpad.

I have tried every recommendation I could find here or in other discussions: like different trackpad settings, resetting the trackpad-configuration, deactivating the new desktop features (like stage manager), blocking background processes, starting in safe mode. Nothing has helped.

One method to narrow down the problem further: I used an external trackpad, with which the right click worked excellently.

Edit: The trackpad was replaced by Apple Service. Unfortunately that wasn't successful.

Apple Macbook Pro M3 (2023) 14", MacOS: Sonoma 14.2.1

4
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Dec 17, 2023 at 15:55
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. To get notified when this question gets new answers, you can follow this question. Once you have enough reputation, you can also add a bounty to draw more attention to this question. - From Review
    – IconDaemon
    Commented Dec 17, 2023 at 16:42
  • 1
    From my point of view it answers the part "can someone reproduce this behaviour with their machine as well", so even though it's not a solution, it's definitely an answer I appreciate. Commented Dec 20, 2023 at 8:37
  • I have the exact same issue and I have no clue how to fix it either, it's such a massive productivity downgrade from my older MacBook
    – Isa
    Commented Feb 18 at 17:19
0

Identifying the Cause of the Trackpad Issue

I understand the issue you're experiencing with the trackpad on your MacBook Pro. Identifying the cause of such behavior can be challenging, especially when it's uncertain whether it has been present since the beginning or if it has recently started.

Reproducible Behavior and Possible Solution

You have provided a detailed description of the problem and even a reproducible scenario, which is helpful for troubleshooting. It appears that the secondary click (right-click) in the bottom-right corner doesn't consistently work as expected.

While I don't have the exact solution, I can offer some suggestions to help you further:

1. Update your macOS

Ensure that your MacBook Pro is running the latest version of the operating system. Sometimes, software updates can address trackpad-related issues. (I am sure yours is, but it might be helpful to include if anyone else is experiencing the same issue)

2. Reset the trackpad settings

  • Go to System Preferences > Trackpad.
  • Try resetting all trackpad settings to their default values.
  • Then, configure the secondary click again and observe if the issue persists.

Alternatively, if you are familiar with using the terminal, you can try resetting the trackpad settings with the following command:

defaults delete com.apple.AppleMultitouchTrackpad

Running this command in the terminal will help reset the trackpad settings to their default values. After executing the command, you may need to log out and log back in or restart your MacBook Pro for the changes to take effect.

3. Check for third-party software interference

It's possible that certain third-party apps or utilities might be conflicting with the trackpad functionality. Follow these steps:

  • Boot your MacBook Pro into Safe Mode by holding the Shift key while restarting.
  • Check if the problem still occurs in Safe Mode.
  • If the issue doesn't manifest in Safe Mode, consider reviewing recently installed or updated apps and disabling or removing them to pinpoint any conflicts.

If none of these suggestions resolve the issue, it might be worth considering reaching out to authorized service for further assistance. They can diagnose and address any potential hardware-related problems.

Good luck!

0

Not the answer you're looking for? Browse other questions tagged .