Ever since I updated Safari to v5.1.4 on my MacBook Pro (Lion) I've been unable to load Google Reader. I can load and view Google Reader in Chrome on my MBP, but not the latest version of Safari.

When browsing to Google Reader, the normal yellow Loading box displays, but eventually this is all that shows up: Screen shot

I'm running Safari 5.1.4 on Mac OS 10.7.3. I've tried all of the suggestions listed on the page, and nothing works. How do I get it to load?

  • Since Safari 5.1.4, I can't use Google Apps or any of its services, including Gmail and Google Calendar. While Google Maps works, the Get Directions feature does not. I can still use all these features in FireFox 11, so I know there is nothing wrong with my Google Apps account. I am already using only 32-bit mode in Safari, so the problem must be more than just that.
    – user9290
    Mar 26, 2012 at 20:48

2 Answers 2


Had the same problem. Tried resetting cache, making sure latest Flash was installed, turning off all extensions, etc. Turns out changing Safari to 64-bit mode was what did it this time. Open Finder, Applications/Safari, "right-click" Get info (or command + "i"), uncheck "Open in 32 bit", restart Safari. Hope that helps!

After the fact: Apple released Safari 5.1.5 this afternoon. The update addresses this 32-bit issue specifically.

Safari 5.1.5 update

  • Your answer resolved the issue. Do you know what, if any, the repercussions of changing to 64-bit may have?
    – tlatkovich
    Mar 26, 2012 at 20:30

Try to disable all the plugins and see if it works then.

You said you cleared your browser cache, did you try to "Reset Safari"? It's in the Safari menu. It will clear the cache, the cookies, etc. You'll then have a "clean" Safari.

  • If by plugin you mean extensions, then I already had that feature turned off. I tried resetting Safari based on your recommendation. I reset all options other than saved usernames and passwords and other autofill data. After restarting Safari and logging back into Google Reader I am still unable to load Google Reader.
    – tlatkovich
    Mar 26, 2012 at 14:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .