0

Issue

When trying to use Finder, the window will freeze and become unresponsive. Trying to relaunch or force quit fails. The only thing that fixes it is a full restart of the computer.

When trying to use Spotlight, anytime I try to launch a program with it, it will get the Beach Ball of Death (BBOD). After a minute or so, it will crash, the program will have not launched, and it will successfully restart spotlight (I think).

When trying to use applications that access the filesystem, it will cause those applications to freeze for long periods of time before they become responsive again. This does not happen with every application, notably DaisyDisk has no problem whatsoever, and accessing things with shell (I use fish) works fine.

And this started to happen later, but my background is also freaking out, showing up 'sharded' or like it's got screen tearing where half the background is black. Same thing for the login screen. It's like it's in negative, where the mouse is blue, the entire background is black, and there's a weird box around the cursor. The password input is cyan (for the dots).

Steps I've taken

I've tried many things:

  • removing most login items
  • uninstalling a bunch of unused stuff
    • anytime I try to uninstall stuff it freezes due to trying to access the file system
  • I've tried removing the Finder and Spotlight plist files
  • I've tried using Disk Utility to verify all drives
  • I've tried Safe Mode and though it seems to work, the problem will come back if I stay in safe mode long enough
  • I've cleaned out caches using Onyx
  • I've looked through the Console.app and I quite a lot of errors, but that's not necessarily a bad thing, but one thing that does stick out to me is:
    • Bad volume: /Volumes/BOOTCAMP
  • I've tried reinstalling Ventura
    • I got the following error storage system verify or repair failed -69716
    • it seemed to work for Finder
    • but apps still are struggling to access files/create folders
    • spotlight still crashes

Other steps I've taken

/πŸ”’ on ☁️  (us-west-1)
❯ cat /etc/auto_nas
[bat error]: '/etc/auto_nas': No such file or directory (os error 2)

/πŸ”’ on ☁️  (us-west-1)
❯ cat /etc/auto_master
───────┬──────────────────────────────────────────────────────────────────────────────────────────────────────────
       β”‚ File: /etc/auto_master
───────┼──────────────────────────────────────────────────────────────────────────────────────────────────────────
   1   β”‚ #
   2   β”‚ # Automounter master map
   3   β”‚ #
   4   β”‚ +auto_master        # Use directory service
   5   β”‚ #/net           -hosts      -nobrowse,hidefromfinder,nosuid
   6   β”‚ /home           auto_home   -nobrowse,hidefromfinder
   7   β”‚ /Network/Servers    -fstab
   8   β”‚ /-          -static
───────┴──────────────────────────────────────────────────────────────────────────────────────────────────────────

/πŸ”’ on ☁️  (us-west-1)
❯
❯ diskutil info disk0 | grep SMART
   SMART Status:              Verified

/πŸ”’ on ☁️  (us-west-1)
❯

I tried removing the QuickLook folders as well, but only did the user folder to start. The other folders wanted sudo so wanted to check here first if that should be my next course of action.

rm -rf ~/Library/QuickLook/

I don't have Google Backup & Sync though I did at one point. Nothing in the sidebar. I do have Dropbox, but it's still installed, not removed, and it works fine.

I do see this in the Application Support directory though:

❯ ls ~/Library/Application\ Support/Google/Drive/
Permissions Size User  Date Modified Name
drwxr-xr-x     - tyler 20 Sep  2021  drive_fs_upgrade
.rw-r--r--@ 659k tyler 10 Oct  2022  finder_log.log
.rw-r--r--     0 tyler 11 Jul  2020  findextmp.lock
.rw-r--r--   20k tyler 11 Jul  2020  global.db
.rw-r--r--     0 tyler 10 Jul  2020  ip_lockfile
.rw-r--r--     0 tyler 10 Jul  2020  lockfile
drwxr-xr-x     - tyler 11 Jul  2020  user_default

I want to exhaust all resources before I nuke entirely and start over.

removed the plist files

well I really don't want it to be the sata cable or ssd, but I'm not sure how I'd rule those out.

not sure if I should do this? Not sure how to tbh.

System info

2.4 GHz 8-Core Intel Core i9
Intel UHD Graphics 630 1536 MB
32 GB 2667 MHz DDR4
Macintosh HD
13.3.1 (a) (22E772610a)
14
  • To be candid, this is much to lengthy and broad to follow. When you get the wait cursor (the spinning beachball of death), it means that the system is waiting for something before it can move on. It could be from either RAM or your disk or another application. Before you start taking drastic steps, boot into Safe Mode and see if the problem persists.
    – Allan
    Commented May 17, 2023 at 2:50
  • I clearly laid out all the things I've tried. There's no such thing as "too broad" when you're detailing out the problems you've tried. I gave as much information as possible that is 100% relevant to the problem at hand. If you had actually read to literally the fifth bullet point you would have seen that.
    – snowe2010
    Commented May 17, 2023 at 5:27
  • Is this a Mini or a MBP?
    – nohillside
    Commented May 17, 2023 at 5:46
  • @nohillside it's a MBP. 2019 16"
    – snowe2010
    Commented May 17, 2023 at 5:51
  • 2
    I would start with a cleaning as @nohillside suggested. Too much heat will cause the CPU to limit performance. Unfortunately, the MBP of that vintage is no longer user upgradable - all components are soldered. You could try booting into Diagnostics (Hold D while booting) and see what it reports. You don’t need to wipe the drive to try a reinstall, just install macOS to an external drive (even a flash drive will work; > 32GB). If the problem goes away there, it’s your drive. If not, it’s narrowed down to memory or CPU
    – Allan
    Commented May 17, 2023 at 18:44

0

You must log in to answer this question.

Browse other questions tagged .