0

Back in 2020, when I updated my 2017 iMac to Catalina, I found that the Samba shares on an old Linux box (the same one that was our original automated backup controller) wouldn't mount because Catalina had removed support for that version of Samba. My SMB shares won't mount under Catalina! What's wrong?

Now that I've got the backup controller running on an old Mini, I've revisited the situation. I'm using the Catalina iMac, rather than my new Ventura Mini, as a Guinea pig for this, and I find that after adjusting the Applescript that automatically runs at sign-on to point to the correct IP address (and adding a third SMB/AFP share to the script, it always asks me for user-ID and password, and which directory to connect to, in spite of the fact that all that is explicitly specified in the script. The script entries are of the form:

try
    open location "smb://uuuuuuuu:[email protected]/dddddddd"
end try

where uuuuuuuu is my user-ID, and pppppppp is my password, on the box hosting the SMB share, at local IP address xxx.xxx.xxx.xxx, and name dddddddd.

Does anybody know what's wrong now? Or if there's an easier way to automatically connect to specific SMB/AFP shares on login?

6
  • I prefer to use the shell (Zsh/Bash). Try mounting the drive manually first with the command mount -t //user:pass@host/share /Volumes/Mount_Point. Be sure to create the mount point first with the command sudo mkdir /Volumes/mount_point_. Let me know what your results are.
    – Allan
    May 16, 2023 at 17:14
  • Names have been changed to protect the innocent. "mount -t //[email protected]/Shared /Volumes/Shared" didn't even ask me for a password. It just gave me: usage: mount [-dfrkuvw] [-o options] [-t external_type] special mount_point mount [-adfrkuvw] [-t external_type] mount [-dfrkuvw] special | mount_point May 16, 2023 at 17:35
  • Sorry…that should say mount -t smbfs ….
    – Allan
    May 16, 2023 at 17:36
  • That asked me for a password, but repeatedly gave me mount_smbfs: server rejected the connection: Authentication error mount: /Volumes/Shared failed with 77 May 16, 2023 at 17:40
  • Authentication error means you have an issue with your username/password. Were you ever able to mount this share?
    – Allan
    May 16, 2023 at 18:00

1 Answer 1

0

Doing a Google search on "macintosh ventura automatically mount SMB share on login," I think I found something that looks fairly promising:

https://discussions.apple.com/thread/254547407

In short, it tells you to just put the share in your login items.

Never even thought of doing anything like that before asking for help. I ran a test, and it seems to work, so far at least. The OP of the Apple thread appears to be having some sort of difficulty with the canonical solution, but at least now I know what the canonical solution is.

It works for all three shares. Working directly on the M2 Mini, I've removed the lines that attempt to mount the shares from the script, added lines to initialize the view on a third share ("BT-shares") to "icon view, no sidebar" (the same as the other two) and close its window, and left the rest of the script (initing views and closing windows, and installing a Mousecape to change my default mouse pointer to a brown-and-white rodent named "Willard") as it was.

And even better, the mounted shares retained the icons I'd given them (unmounted disk packs for an IBM "Merlin" mainframe drive, in colored pack-covers)

picture of my mounted volumes

I will, however, note that the Apple discussion has one error: when you bring up the "add" window for open-at-login, your mounted shares are NOT going to show up in the desktop, but rather under Locations.

2
  • @Tetsujin: Easy enough to do, given that the whole linked-to discussion can be summed up in the one sentence I just added. May 19, 2023 at 17:36
  • There ya go then. Now we'll know if the link ever breaks ;)
    – Tetsujin
    May 19, 2023 at 17:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .