1

I recently bought a MacMini M2 Pro running Ventura 13.3.1. Both my bluetooth mouse, and my logitech mouse with separate USB dongle move choppy over the screen. It feels as if the CPU is too busy with other stuff, or the mouse "task" is not getting enough priority. Both mice work fine on my old iMac and MacBook. A wired mouse works fine.

I contacted Apple support, and oddly enough they created a ticket named "keyboard lag". When I pointed out it is about mouse lag, he said: yes, I understood you. So this indicates this is known problem that for some people also affects the keyboard. After spending several hours with Apple support (up to a complete reinstall of MacOS!) I am starting to lose my faith in them and get the feeling they are just keeping me busy and beat around the bush.

Googling this problem indeed finds many more people suffering from this. I read that the MacMini M2 worked fine with Ventura 13.1 for most users. The problems started with the upgrade to 13.2. That suggests it is not a hardware design problem with the MacMini M2, but only related to software.

Any thoughts how I can resolve this problem?

9
  • You can check CPU usage in Activity Monitor -- but given the computing power of the M2 Pro, I doubt the CPU is unable to provide enough resources! If a wired mouse works fine, then that likely points the finger at Bluetooth connectivity.
    – benwiggy
    May 12, 2023 at 8:29
  • If it happens both with native Bluetooth and with the Logitech dongle, the issue might be rather with the wireless connectivity than with the OS. Do you have a DECT phone or a WiFi router close-by, or other wireless devices? If you set up your Mini in another room, does the problem persist?
    – nohillside
    May 12, 2023 at 8:36
  • Related apple.stackexchange.com/questions/263965/…
    – nohillside
    May 12, 2023 at 8:37
  • @nohillside my setup did not change except that I replaced my iMac with a Mac Mini. Same monitor placement (did not use iMac screen), same mouse placement, same keyboard. May 12, 2023 at 16:39
  • Might be worth trying another room nevertheless, just to be sure. Or wait for 13.4.
    – nohillside
    May 12, 2023 at 17:00

2 Answers 2

1

I had the same issue with a radio dongle wireless Logitec mouse. Worked fine previously and suddenly started stuttering. Tried a different wireless mouse, same problem. I had my dongle in one of the USB A ports on the back of my mac mini m2 pro (tried both of them), no change, stutter remained.

When I tried to plug the dongle into one of the USB A ports of my cart reader which is connected to one of the USB-C/Thunderbolt ports and the stuttering stopped.

I don't think it has anything to do with distance or interference. I tried hanging the hub with radio dongle in it all the way to the back under my desk (my mini basically stands next to my mouse on my desk) and it still doesn't stutter.

I've tested this with two mice that previously stuttered the last 24 hours and I had no stutters at all.

3
  • Interesting! So, apparently the USB-A ports have some latency/stutter issue, wereas USB-C does not. I will borrow a hub and try the same. Thanks for the valuable info! Jul 6, 2023 at 15:59
  • Seems that way. Really does look an USB-A port issue. Still can't really figure out how a wired mouse doesn't have the issue in the same port, so we can't completely rule out rf interference I think 🤔
    – Thomas
    Jul 7, 2023 at 16:31
  • I am also suffering from this issue, only on the intel-chip 2019 MBP 16. Using same USB-c dongle, same wireless adapter and same logitech mouse (G700s), it does not stutter at all on the M1 MBP 13, but stutters/jitters on the intel-MPB 16 Aug 19, 2023 at 20:56
0

I tried adapting to my Mac mini M2's USB C port, but that did not fix it for me.

My issue actually was interference. I had my Performance MX plugged into a charge port on the power strip and the dropouts got worse as I moved the receiver further away. I moved the charge cord to the hub the receiver was in, and now it works great.

The strange thing is that the bad setup had no issues on my Dell Laptop, so I had assumed it was a software glitch instead of grounding.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .