Some time earlier this year I started getting my child's screen time requests in the Messages app. This has become really annoying. The whole thing seems half-baked and there are several issues:

  1. Each request appears multiple times
  2. The request, which goes to both my wife and me, shows up as coming from my child, but the request text says "Mama asked for more time".
  3. I send my messages to my laptop as well, and there these messages all show a spinning fan while Messages loads more information, I guess.
  4. It really locks up the Messages app. Sometimes it causes the app to crash. "Messages quit unexpectedly."

I tried searching for ways to disable this but I didn't find any good answers on the Apple support site. I can't see actual messages from my kid for all these stupid screen time requests.

Is there a way to disable this again?

  • Try to see if in Settings > Screen Time > [family member (kid)] > App Limits > [app/category name] and disable "Block at End of Limit". It should just show your family member a notification saying time limit was outimed without sending you a notification. Tell me if it worked!
    – Thinkr
    May 9, 2023 at 12:40
  • 1
    Hi, @Thinkr, I don't think what you suggests addresses the issue. The requests are not automatically generated. When the allowed time ends, my child is explicitly asking for more time, and that request, which used to show up as a notification alert, now appears in Messages.
    – Sushil
    May 20, 2023 at 6:57
  • Yes, I understood that. But your child asks for more time because the app/website is blocked at the end of limit. Disabling that setting will allow your child to use the app/website even after the limit has expired and therefore, they will not send you a request.
    – Thinkr
    May 20, 2023 at 7:13
  • 1
    Thanks for bringing this up. This is very shortsighted and totally uncalled for 'feature' that should be disabled by default. Some childless Apple developers came up with this bananas idea, (falsely) hope they can revert it soon Oct 11, 2023 at 0:54

1 Answer 1


I have had messages get out of whack before and it’s not fun and very irritating. I think there are two paths forward for you, pick the one that’s most interesting and least painful and leave the other for if the first isn’t enough.

  1. Call Apple Support - they have the most experience with Apple ID and parental controls and it’s very likely you are in with a bunch of others with the same pain. They also have access to the server side and can help you flush things. I know you may need them if self-help doesn’t work, so going there first could be the fastest.
  2. Wrangle your messages - you’ll disable it on all but the iPhone and then make some changes to your messages account - then test screen time and decide to take the simpler problem to Apple or have it solved for just the iPhone and expand back to all messages devices you want.

The DIY steps are needed in some cases since Apple generates a unique encryption key for each device registered and it appears they also overload the various email addresses and SMS identities that can be attached to one Messages device.

  1. Take inventory of all devices that might ever have been signed in to your Apple ID and make sure they all are deregistered from Messages or dissociated from your account.
  2. Apple document for finding all signed-in devices: Check your Apple ID device list to find where you're signed in
  3. Delete all you don’t need and can’t touch - they will come right back to the list as soon as they power on and connect to the internet - this is a soft delete unless you’ve lost the device - then it won’t come back again. You might lose a backup on the device - so think about iCloud backups before you delete an iOS/iPadOS device.
  4. Take screenshots of the Messages settings on each of your devices.
  5. Here is the article on using different emails and/or SMS to identify with Messages service: If your iPhone sends text messages from your email address
  6. Remove devices - most annoying first, so Mac and iPad and leave one iPhone (the one with cellular service for your primary cell number) active.
  7. First remove SMS forwarding: Set up iPhone to get SMS messages on Mac and Set up Messages on iPad
  8. Then sign out of messages on the Mac - Messages app settings, iMessage tab - screenshot and then sign out.
  9. Repeat for iPad - Settings app - go to Messages - toggle off iMessage
  10. On the iPhone: if you have multiple emails, I might drop them all or most of them - then trigger some Screen Time requests - make sure they only go to the iPhone.

If you’re comfortable with things off - let the system on the Apple side only deliver messages to the iPhone overnight and then test before adding back your accounts.

I hope you don’t need all of this, but it’s quite a process when things get janky and we don’t have access to the server side to know where the messages are getting piled up for delivery to you. If you think Apple just needs to revert their decision, you’ll have to go the Apple support method if there’s really no extra duplication of the messages and enabling iCloud sync so at least the message gets read once across all devices.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .