My internal 250GB failed on me the other day, so I replaced it with a new SSD and HDD combo. I have the failed disk connected via USB/SATA, but it will not mount. However, it shows up under System Profiler.

The following is from System Profiler:


  • Capacity: 250.06 GB (250,059,347,968 bytes)
  • Removable Media: Yes
  • Detachable Drive: Yes
  • BSD Name: disk4
  • Product ID: 0x0731
  • Vendor ID: 0x05e3 (Genesys Logic, Inc.)
  • Version: 90.94
  • Serial Number: 37007
  • Speed: Up to 480 Mb/sec
  • Manufacturer: Genesyslogic
  • Location ID: 0x24130000 / 4
  • Current Available (mA): 500
  • Current Required (mA): 192
  • Partition Map Type: GPT (GUID Partition Table)
  • S.M.A.R.T. status: Not Supported
  • Volumes:
    • disk4s1:
      • Capacity: 209.7 MB (209,715,200 bytes)
      • BSD Name: disk4s1
      • Content: EFI
    • Macintosh HD:
      • Capacity: 184.48 GB (184,484,454,400 bytes)
      • BSD Name: disk4s2
    • Unknown:
    • Unknown:
  • Have you tried repairing it with Disk Utility?
    – Tuesday
    Commented Mar 26, 2012 at 1:18
  • It will not even show on Disk Utility.
    – Logan
    Commented Mar 26, 2012 at 2:37

2 Answers 2


By SSD and HDD combo do you mean something like a Seagate Momentus?

I'm really confused by you saying that the disk failed (how did it fail?) but then you have connected it by USB and you expect it to work?

The report you posted doesn't show a

Content:    Apple_HFS

as you might expect to see under Volumes, so it appears to have been corrupted.

If data on this volume is vital and you don't mind spending money to get it back then unplug it right away and take it to a professional recovery service.

If it would be just "nice to have back" then you could try using the First Aid tab of Disk Utility, and see if it can recover the partition(s).

  • Sorry for the confusion, what I meant with a SSD/HDD combo is that I replaced the failed hard drive with an SSD and an HDD where the optical drive was, apologies. When I said the disk failed, I meant that the Mac OS would not boot as the disk itself would not mount. It doesn't seem to be doing anything in Disk Utility or Disk Warrior, so I think I'll just tuck it away and wait until I can get it professionally restored. Thank you!
    – Logan
    Commented Mar 26, 2012 at 2:33

I had the same problem . 2007 MacBook Pro - an SSD (Patriot Pyro SASA III 120 GB) that I imstalled 20 months ago failed. Patriot (excellent !) replaced the SSD immediately.

Neither the Disk Uitility nor the Time Machine Restore would recognize the SSD when installed internally. The disk profiler, however, could see it.

enter image description here

I formatted the SSD via an External Housing and a USB connection, replaced it in the internal slot - same result. - Checked the cables, the connections, ( verifying by replacing the SSD with an old HD ( it worked! ) Decided to disassemble / reassemble one more painstaking time - I must not have been careful enough.....- same result - failure to see the drive. ( The definition of insanity ....doing the same thing over and over expecting a different result.)

Final attempt. Placed the old HD in the Internal slot, connected the Time Machine External Drive to USB1 and connected the Patriot SSD ( via an External housing) to USB2; Ran Time Machine Restore - 2.5 hours later, the SSD was a restored drive - well at least I could data mine........

I carefully disassembled everything, super carefully reinstalled the SSD in the internal slot, closed it all up and hit the Start-up button.

It worked! The Machine is as good ( and much faster than ) new........

I hope this helps someone!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .