2

I spent an enormous amount of time working on multiple sheets in a single excel file. Now, it's gone and just has an old version. I'm not sure why it didn't get saved (I typically save things way more often than needed), but that's besides the point now.

  • I'm on a Mac running version 16.61.1 of Excel and macOS Monterey 12.2.1

  • Autosave was not on.

  • I am willing to do anything to get this data back, including Disk Drill-esque methods.

  • "Browse version history" is grayed out.

I'm asking this here because all of the solutions I've seen and tried only are doable on non-Mac computers. If there's any information I'm not remembering to include, I'm more than happy to give additional details.

Here is a list of things I've tried:

  • Checked trash and the time machine.
  • Checked temporary files: it looks like there's a newer temporary file instead that is too small in size to be my sheets. (New temporary files appear not to overwrite new ones in Excel 365, though.)
  • Tried the solutions here (I'm on version 16.61.1 of Excel and macOS Monterey 12.2.1, so these menus don't exist on my version.) Similarly, I don't appear to have the correct version to do this because I have Excel 365.
  • Attempted to find any "previous versions" by opening the properties/get info page of the file.
  • I searched for .tmp files in Finder, but didn't see any of those files.
  • I have installed EaseUS Data Recovery Wizard, and it is loading: I will try searching for .tmp files within it.
  • I've tried solutions like this that don't work on macOS and Excel 365.
  • I've tried finding "Unsaved Workbooks/Manage Workbook," which doesn't seem to exist on Excel 365.

Not much time has elapsed since the creation of the file I want to recover, I have barely used Excel since (just for troubleshooting), and I have 177 GB of unused storage on my computer.

I've found a ~ar4014.xar XAR archive document here: "/Users/user/Library/Containers/com.microsoft.Excel/Data/Library/Application Support/Microsoft/~ar4014.xar". The file is 25 KB, which is about what's expected for the file I'm trying to recover. It has the correct number of sheets: there are files within the .xar that say "sheet2.bin", "binaryIndex3.bin", "sheet6.bin.rels", etc. The data is definitely in the .bin files within the .xar file: I can see the correct English text in the .bin when I converted .bin to ASCII.

11
  • 1
    Please don't cross-post to multiple SE sites. Pick one & stick to it, or flag for migration. Is cross-posting a question on multiple Stack Exchange sites permitted if the question is on-topic for each site? - superuser.com/questions/1781338/…
    – Tetsujin
    Apr 28, 2023 at 11:52
  • I'd say this one. It's picking up reopen votes already, with the new info.
    – Tetsujin
    Apr 28, 2023 at 11:58
  • 2
    Bad idea, btw, to install new software to try find a lost file - you could just as easily have overwritten it in the attempt. You should prevent writes to the drive as much as possible while you're doing this. It might be in Times Machine's local storage.
    – Tetsujin
    Apr 28, 2023 at 12:10
  • I've found a .xar file which seems to contain the data of the sheet, though I'm not sure how to view it or get it into sheet format. Time Machine doesn't seem to be storing anything at all, even locally. It just shows the current files.
    – BigMistake
    Apr 28, 2023 at 12:18
  • The solution is just to rename it to a .xls file and open it.
    – BigMistake
    Apr 28, 2023 at 12:50

1 Answer 1

0

You're almost certainly out of luck due to macOS APFS copy on write functionality and how excel writes binary files to recover the actual saved version. Look in the folder ~/Library/Containers/com.microsoft.Excel/Data/Library/Application Support/Microsoft/ for any .xls or .xar files - depending on the size of them you might have internal versions that didn't get saved out fully to where you expected to store the data file.

Note: You must change the file extension from .xar to .xls (not .xlsx) to open the file.


Assuming you have no remnants of the file from above, and if cost is no issue you should power off the Mac immediately and get a quote for professional data recovery.

Every second you use the Mac, the free space can and will be overwritten reducing the chance that data recovery is successful.

Doing this yourself is not likely to work - in the past undeleting files was easier since the file allocation was basic, the directory entry was trivially marked empty and the data structures far simpler.

The only thing you might do is borrow / use a spare Mac and mount your drive in target disk mode or boot to recovery and see if any APFS snapshots exist. That would be the only case where you could examine the snapshot times and with help - mount that snapshot and see about copying the intact file back to an external drive.

Again, that all presupposes you saved the file and you got a snapshot at a time after the good save and before the data was lost.

Sadly, in most cases - doing the work is cheaper, faster than trying to do all the data recovery steps. Data recovery works far better for simpler file types (music, photos, etc...) than one of the very complicated file formats like Adobe Illustrator layered documents or Microsoft Word / Excel - those are the least likely to have a good result in my experience.

Sorry for the bad news. It's too late to get serious about hourly backups and auto save or learning if you can trust the OneDrive versioning of Office documents. We went all in with OneDrive once we realized how well auto save and versions worked in practice for people like you.

1
  • There are some ways to recover unsaved Excel files like "Run Excel data recovery software", "Check the autosave folder" or "Check your backup folder". It also has AutoSave and AutoRecover features to protect files. It automatically saves a new Excel document that has been created but not saved yet and can help users retrieve unsaved Excel files. There is also third-party software available here easeus.com/mac-file-recovery/… you can check the steps Nov 22, 2023 at 14:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .