1

I need to transfer a large number of files to a new M2 MBP, from another Intel MBP running Monterey 12.4. I have tried transferring over the network and it's taking far too long, so would like to use USB-C.

I've followed the instructions to shut down the M2 and reboot into Recovery mode, then choose Utilities > Share Disk > Start Sharing.

The new MBP then appears under Network in my Intel MBP, but it has a question mark next to it. When I select the MBP, I can see its "Macintosh HD", and can choose "Connect As..." but am unable to connect either as a Guest or Registered User. Each time, I wait a minute or so, then get "There was a problem connecting to the server MacBook Pro".

I've tried rebooting both and checking the cables (FWIW, I'm using the brand new USB-C cable that came with the new MBP). If anyone has any ideas on why this isn't working, I'd appreciate it!

1 Answer 1

1

Instead of using SMB file sharing, use scp via Terminal instead. SMB file sharing has been a little flaky on recent versions of macOS where as ssh and scp are rock solid. However, it will require a little bit of Terminal cli-fu.

Pre-Reqs

You’ll need the following prior to making the connection and copying file(s):

  • Enable Remote Login in Settings/Preferences.
  • The IP address of the Mac you want to connect to (I assume the Intel Mac).
  • Verified that the remote machine can be reached. (Test with ping ipaddress)
  • The path to the file/folder you want to copy (save to your clipboard if you wish)

First Step: Make sure you can log in

Issue the following command where user = the username of a registered user on the machine you’re connecting to and ipaddress = the IP of that same machine:

ssh user@ipaddress

You should get a password prompt. Enter it and if successful, you’re connected to the other machine. Type exit to disconnect.

Second step: Use scp to copy you file(s).

Just like the command above, you’re going to connect to your Mac but this time with the file/folder path you got from the pre-reqs:

scp user@ipaddress:path/to/files/foo.bar destination/path

Example: copying all PDF files in remote Downloads to local Downloads:

scp user@ipaddress:Downloads/*.pdf ~/Downloads/

Again, you’ll get a password prompt and if correct and your path is valid, you’ll see a transfer status message letting you know how much has copied and the elapsed time. When it’s finished, it will automatically disconnect.

Extras

  • You can streamline the ssh/scp login process with ssh keys; you won’t have to enter a password See: How to SSH in one line for full instructions

  • If you use iTerm2 instead of Terminal, you can configure a ⌘ Command-Click action to scp the selected file. See: iTerm2 Symantec History

  • If you’re having difficulty connecting your two computers over Thunderbolt, Apple has an excellent Support Document entitled Use IP over Thunderbolt to connect Mac Computers. You can try and setup DHCP/DNS, but for this, I recommend manual IP settings. Just make sure you’re on a different subnet than your regular network. For instance, your regular network is 192.168.1.X, then use 10.0.0.X.

4
  • Thanks for this detailed reply! Won't these steps result in the data being transferred over the network rather than USB-C, however?
    – jessica
    Commented Apr 26, 2023 at 19:54
  • When you connect both Macs via the USB, you are in effect creating a local network. So, yes, you are correct, but these networks commands move the traffic over the USB. Just make sure you get the IP of the USB not your WiFi. Let me know if you need instructions on how to get that info.
    – Allan
    Commented Apr 26, 2023 at 19:56
  • Wow, I had no idea that the USB connections would create a local network, I would love to use scp. I have exhausted my best guess and did not find the IP address for the USB under the System Report. I'm also seeing that both devices say "No device connected" in the System Report under either USB or Thunderbolt/USB4, so I am wondering if the charger cable is not a sufficient enough data cable. Please let me know how I should find the USB IP address, in the meantime I am running out to get a Thunderbolt cable! :)
    – jessica
    Commented Apr 26, 2023 at 20:02
  • 1
    I’d write out the instructions, but Apple did a better job. :-)
    – Allan
    Commented Apr 26, 2023 at 20:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .