2

This question is not about issues remapping shortcuts or changing input type.

I was given a MacBook Pro by my work a couple of months ago. Now, I've always used an external mechanical (Azio) keyboard (through a Dock) with it just fine.

Last week I updated the OS and now the keyboard mapping is entirely nonsensical and unusable. What do I mean? Here are some example mappings:

  • If I press Esc I get ]
  • If I press Backspace I get \
  • If I press qwerty I get x4ly1

Searching online hasn't been particularly useful as most search results show help with configuring input types, languages, or shortcuts.

I should note that keyboard behavior stays the same if I do not use the dock, that I do not have these issues with my other mechanical keyboard (which is at the office), and that the keyboard with the issues functions just fine on my Linux and Windows systems.

My mac is running Ventura Version 13.3.1 (22E261).

Thanks in advance.

6
  • Have you asked the support for the people who make that keyboard? Apr 26, 2023 at 1:49
  • The published troubleshooting guide for it does not list any problems like it, and from the looks of their support page they seem to have dropped support for this particular model; I submitted a request just in case already.
    – alonso s
    Apr 26, 2023 at 3:41
  • 1
    Can you enable the Virtual Keyboard to see which keys are being registered? Also, just to confirm, does the keyboard still work properly on a different computer?
    – Allan
    Apr 26, 2023 at 4:17
  • Try going to System Settings > Keyboard > Modifier Keys > Reset to default and pressing "OK".
    – Thinkr
    Apr 26, 2023 at 6:49
  • 1
    Maybe try resetting the keyboard recognition. It used to be 'Change keyboard type' in system prefs > Keyboard - I've no idea where they may have hidden it in Ventura :\
    – Tetsujin
    Apr 26, 2023 at 8:37

1 Answer 1

0

I figured it out everyone, and I hope it helps other people with mechanical gaming keyboards.

The nonsensical mapping occurred while the keyboard was in NKRO mode. Switching it to 6KRO mode solved the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .