1

I am getting frustrated with my computer. I have a Macbook Pro 2021, M1 chip running Ventura 13.3.1.

A dialog box keeps popping up, almost immediately disappearing, and then coming back, and quickly going again. On and on and on. This box is asking if I want to "allow the application 'Hub' to accept incoming connections". Always the same message. I have no idea what the application "Hub" is.

A similar question has been asked before but all with applications I recognize so let me put what I've tried so far:

  • Checked my firewall. "Hub" is there.
    • I tried setting it to "block connections" from that app. This did not work. I also tried setting it to "block" and then restarted my computer but when I restart, it resets back to "accept.
    • I tried using the minus sign to remove "Hub" from the list. The box still kept appearing and after a restart, "Hub" appeared back in the firewall list.
    • I did not try blocking all connections or accepting all connections as I want to keep my firewall as it is, if possible.
  • Edit: I even tried clicking the "Accept" and "Deny" buttons (with some fast reaction time) and this didn't work either

As I mentioned, I have no idea where this Hub app is located or how to find it. I don't know if it's part of an Apple application or not but I want it gone or deactivated so this box stops popping up. Typing this post has been a nightmare as the box has come up at least 20 times.

I'd appreciate any help and would be happy to provide more info if needed.

3
  • "Intelligent Hub extends mobile device management (MDM) and mobile app management (MAM) capabilities and enables your company to keep your device secure, compliant and connected. "
    – Thinkr
    Apr 26, 2023 at 6:12
  • I would then ask you : Are you part of an organisation (school, business...) that manages your Mac?
    – Thinkr
    Apr 26, 2023 at 6:13
  • @Thinkr I do go to a university for school but they do not manage my Mac; it is my own computer. My issue happens at home as well as on campus.
    – hotdog101
    Apr 26, 2023 at 12:56

1 Answer 1

1

The answer from another forum: you can right click on applications in the firewall list to view the application in the Finder. In my case, it was a executable (so not even an application) from a 5-year-old installation of Pro Tools that I thought I had deleted many years ago. Removing that solved the problem!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .