I use GMail for push mail on my iPhone. I need that feature to sync my contact, calendar and email with Google. Setup is done using Microsoft Exchange following official tutorial from google at http://support.google.com/mobile/bin/answer.py?hl=en&topic=14252&answer=138740

The problem is, it seems the push mail downloads all of my labels on GMail, which is 200 labels, and it annoys me. (Screenshot below)

enter image description here

Is there any solution to remove that Label/Folder?

2 Answers 2


You can disable these from your Gmail Preferences.

Go to Settings > Labels, and uncheck all the labels you don't wish to appear on your iPhone. Once done, the iPhone should update accordingly. If not, just delete the account and add it again.

For example, here are my settings:

enter image description here

  • did you mean remove the "Show in IMAP" checkbox?
    – GusDeCooL
    Commented Mar 25, 2012 at 20:56
  • @GusDeCooL: Yes, that's correct. Uncheck anything you don't want to show. Commented Mar 25, 2012 at 21:01
  • not works, already try delete my account and adding it again. That only work if i using IMAP through "gmail" option setting on my iPhone. Notice i using option microsoft exchange here, i need use MS exchange because i want to sync my contact too.
    – GusDeCooL
    Commented Mar 25, 2012 at 21:07
  • 1
    Okay, I guess that doesn't work then. Sorry! Commented Mar 25, 2012 at 21:13

You might want to consider using imap instead of MS exchange. It's quite possible to sync your contacts with Gmail. To do this:

  1. connect your phone to itunes and select the "info" tab
  2. Enable the "Sync Contacts" option.
  3. Enable Sync Google Contacts and enter your google details.

Now you can change your gmail to imap as per the settings in sudo rm's answer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .