I have a Mac Mini (2023, M2) and I would like to connect to it and run Safari remotely from a Linux laptop. I am not trying to connect to a Linux (or Windows) server from a Mac client, here the "server" is the Mac Mini, and I am connecting to it remotely. I have tried several things, mainly around trying to get VNC working and, while it works, performance is truly horrible, even just over a fast local network.

It appears that I have X11 installed and forwarding working - if I run xclock over ssh then it duly appears on my Linux desktop.

However, whenever I try to run something a little more substantial, like safari or chrome, I get

anton@mmini:~$ open -a safari
The application /System/Volumes/Preboot/Cryptexes/App/System/Applications/Safari.app cannot be opened for an unexpected reason, error=Error Domain=RBSRequestErrorDomain Code=5 "Launch failed." UserInfo={NSLocalizedFailureReason=Launch failed., NSUnderlyingError=0x60000395ca80 {Error Domain=OSLaunchdErrorDomain Code=125 "Domain does not support specified action" UserInfo={NSLocalizedFailureReason=Domain does not support specified action}}}

Is there any way to run safari over X11/ssh or was that just wishful thinking?

1 Answer 1


macOS does not use X11, so you can't use ssh -X to run graphical Mac applications remotely. Instead, you can

  • use a VNC/Remote Desktop solution to access the whole Mac remotely
  • install an X11-based browser (and probably Xquartz) on your Mac and then run that in an ssh/X11 session

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .