2

Spotlight, at least for launching applications has become part of my muscle memory, but MDS just will not play nice, not matter what I try. I've tried rebuilding the index. I've tried just about every combination of adding files to the privacy list(though a command line du shows MDS still reads them). The only way to get MDS to stop pinning my CPU to the max, is to drag my entire user folder into the privacy list, but that seems to mess up even using Spotlight for Applications(some work, others don't).

Does anyone else who's had troubles with MDS have any tricks to get even basic Spotlight functionality to work, without MDS pinning the CPU? Is there a way to limit a particular program to say max 20% of CPU usage?

2 Answers 2

2

How long are you waiting for it to complete its re-indexing every time you make a change? Every time you do any reset, it has to start over… meaning more time with MDS running.

Refresh it once by dropping all volumes into Privacy. Wait 5 minutes, then remove them again. Allow it two days to fully settle.

1
  • 1
    I'd agree: leave it 2 days to settle down.
    – benwiggy
    Commented Apr 15, 2023 at 8:17
1

I am not sure why you would want to do this but take a look at Spotlight Privacy option in System Preferences under Siri & Spotlight.

Here, you can add locations on the Mac to prevent Spotlight from indexing them thereby, decreasing the MDS impact on the CPU.

Another option if you are having a rouge MDS process is to add the Macintosh HD drive to the Spotlight Privacy option, wait for a few minutes and remove it. This will force a fresh index run and that usually fixes the problems.

All the best.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .