0

Disclaimer: Several similar questions to this one have been asked before. Most of those solutions have been tried without luck. TLDR version at the end:

My problem and the troubleshooting steps already tried:

  1. Gf has a 2009 macbook with 2 HDDs running Catalina OS*. Decided to make a clean reinstall of the same OS.
  2. We reboot the laptop in recovery Mode. Use disk Utility and wipe out the HDD that's not running EFI systems.
  3. Head to "Reinstall macOS" and encounter our first problem: There's no internet on the Recovery mode. Can't find the Wi-Fi Icon, plugging in an ethernet cable does nothing, and the Network Utility makes no sense whatsover. Tried restarting, but still nothing.
  4. So we try a bootable USB instead. *After looking around we found out the model doesn't really support Catalina, so we decided to downgrade to El Capitan OS X, figuring it should be faster. Pop out a windows laptop (we don't have any other apple pc), follow a guide to make a macOS X external boot drive using TransMac and a clean USB. We make sure filesystem is GPT and not MBR.
  5. Again in recovery mode we select "Startup disk" to see our startup options, and find the second problem: USB doesn't show as a startup option. Tried different ports, restarted the PC, recreated the bootable using a different usb, and made sure we had the right filesystem. We used the mac's recovery terminal to list all disks with diskutil list and found the laptop did detect the USB, including its EFI partition, but simply wouldn't display it on the startup menu.

After deleting the secondary HDD, the macbook is stuck in an EFI shell - apple logo loop. For whatever reason there seems to be no way back and all the options we could come up for a new OS installation are blocked by this or that. We don't even have a Time Machine back up to try and get back to.

Roundup of the problem (TLDR):

  • After cleaning one of the 2 HDD's, Macbook's OS is broken, stuck on efi shell - apple logo loop that can only be stopped using the recovery boot mode.
  • We can't seem to reinstall the OS through the internet (ethernet and wifi are not detected)
  • Bootable USB's with Mac OS X El Capitan are not detected.

My not-too-tech-savvy ass has run out of options, so i'd appreciate any suggestions. I'll provide any additional info that might help you help me.

8
  • 1
    Those “questions” that you state don’t work, is likely because a) 2009 MacBook doesn’t support USB Boot, b) Internet Recovery wasn’t available to at least 2010 and c) before you wipe any computer, Mac, Windows, or Linux, you need to ensure you have bootable media. The worst time to discover your installer doesn’t work is after you’ve wiped the drive.
    – Allan
    Commented Apr 13, 2023 at 14:05
  • The answer is to make a bootable DVD image for you and boot/install from that.
    – Allan
    Commented Apr 13, 2023 at 14:10
  • @Allan has posted a link to a question where my answer was accepted. I would like to point out that this was a question regarding a MacBook and not a MacBookPro. Also, the model year was established to probably be 2010 and not 2009. Commented Apr 13, 2023 at 16:37
  • Gabriel: Both the Install OS X Lion and Install OS X Mountain Lion applications contained a DMG file which could be converted by TransMac into a bootable USB installer, which would work on certain Mac models. However, the same is not true for El Capitan. The procedure is more complex than given in the link you posted. A procedure, which I have tested to work using certain iMac models, is given here. Commented Apr 13, 2023 at 16:53
  • Gabriel: You stated you have two HDDs. Do this mean the DVD (optical) drive has been replaced with a HDD? If you have a working DVD drive and can burn a DL (double layer) DVD, then you could make a bootable Snow Leopard DVD from this ISO file. See this answer for more information. Commented Apr 13, 2023 at 17:32

0

Browse other questions tagged .