My mac crashed and I am trying to install Xcode 4.2 again, but it doesn't work.

The GUI shows an 'The Installation Failed' error.

In the console a few messages stick out to me. They are:

The domain/default pair of (com.apple.iPhoneSDKInstaller, showAdvancedInstaller) does not exist

The Package "OtherDevDocumentation,pkg" is untrusted. CSSMERR_TP_CERT_EXPIRED

Sometimes it says it can't find the developer tools as well.

When I press Get Info on the Xcode.mpkg inside the DMG file, It says it is only 520KB. Is that supposed to happen?

Can anyone help me fix this issue?

Thanks, Ashley

  • Did you try installing Xcode under a different user account? Commented Mar 28, 2012 at 9:08

3 Answers 3


Just change date to January 2012 or something, it will install just fine. The certificate expired in March.

Updated, steps:

  1. turn off automatic synchronization of date & time
  2. change actual date of the system to 01.01.2012 (for example, prior to 26.03.2012)
  3. install the Xcode
  4. turn the automatic synchronization back on.
  • Welcome to Ask Different. Can you expand on your answer perhaps with corroborating information? I would also consider turning off Date Time updates over NTP
    – Stu Wilson
    Commented Mar 28, 2012 at 20:57
  • 2
    Wooooo. Thank you SOOOOO much. Why would Apple still be distributing something that won't work anymore? Commented Mar 29, 2012 at 9:29

got similar problem here with 10.6 + combo update installed.

after runing software update and installing something called "apple installer update" (com.apple.pkg.update.softwareinstallerupdate.1.0), xcode installer works just fine.


There's a couple things you could try. I had this error when Xcode 4 was first released.

First of all, have you tried rebooting? That solved the problem for me.

Also, in case rebooting doesn't work, just redownload the SDK. It might have gotten corrupted during download.

  • I've tried both those things and no luck. Commented Mar 25, 2012 at 20:00
  • @AshleyStaggs: Then I'd just contact Apple. Sounds like something with your system. Commented Mar 25, 2012 at 20:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .