I had an issue with a partition that refused to be deleted.

The drive is a 500 GB Samsung SSD with (previously) 2 partitions:

  • Macintosh HD (apfs volume with macOS Catalina) -- 250 GB (disk0s1)
  • Untitled (empty macOS Journaled partition) -- 250 GB (disk0s2)

Because the disk util app didn't work, I tried this in terminal:

diskutil eraseVolume 'free' 'delete' disk0s2

Now when I run diskutil list it says (original image):

Photo of output of diskutil list

(I apologise for the image, I don't know how to get a text output from recovery mode)

The main issue there is that it acknowledges my drive size of 500 GB, but it doesn't show the (free space) it's supposed to.

When I run the gpt -r show dev/disk0 command it returns this (original image):

Photo of output of gpt -r show dev/disk0

Beyond this I'm not sure what to do, any help or advice is appreciated.

  • diskutil nor gpt show free space. Why is this critical at this juncture?
    – Allan
    Apr 4 at 19:10
  • Well it's critical because I would like that free space available, to store stuff on.
    – TKFD
    Apr 4 at 19:20
  • The tool you want to use is df. You said you booted into Recovery; ostensibly to repartition your drive? Wouldn’t it be completely empty at this point?
    – Allan
    Apr 4 at 19:24
  • Also try diskutil info <device-identifier> to get free space fromdiskutil
    – Allan
    Apr 4 at 19:37
  • TKFD: I assume you are referring to the free space on the drive. Am I wrong? I think @Allan is referring to the free space on a volumes. Furthermore, the gpt command does shown 250 GB of free disk space between the EFI and APFS partitions. Apr 4 at 19:42


You must log in to answer this question.

Browse other questions tagged .