5

I feel sorry for asking such a basic question. I used to have a banner appearing in the top right corner alerting me.

I don't receive those notifications anymore since I did a clean install of my operating system.

My Calendar view with three alerts set:

Calendar event view with alert


The notification gets in the Notification Center, but I have to click on the date (top right corner) to see it. This defeats the purpose of the notification (am I supposed to click every minute to see if I have a new notification?)

I can see the alert after I click


My Calendar settings:

Calendar settings


My System Preferences settings:

enter image description here


I don't even get notified with sound, although I checked the option "Play sound for notification"

Am I the only one facing this issue?

1 Answer 1

6

I finally found the solution, I had to tick the last checkbox from the notification settings: "When mirroring or sharing the display". I now receive all notification messages again, including the ones from Calendar.

enter image description here

I guess this is because I sometimes use an external display, but the tricky thing is, this was affecting me even when I didn't have any external display plugged in.

1
  • The next question would then be : Why is it affecting you when you didn't have an external display plugged in? :)
    – Thinkr
    Apr 15, 2023 at 10:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .