2

I have a multimonitor setup.

By default the Displays have separate Spaces settign is checked in MacOS, and it causes the dock to hop between monitors if you hover your mouse at the bottom of any of your monitors even unintentionally, which is extremely annoying and frustrating because it causes apps to contract to make space for the dock, and when the dock hops away to another monitor again the apps on the previous monitor to not expand back - so the amount of usable space in the apps is constantly reduced by this constant dock hopping (which is annoying in and of itself).

This solution to disable dock hopping:

Go to System Preferences > Mission Control, then deselect the option "Displays have separate Spaces"

...is not acceptable because then I cannot have full-screen video on one monitor and a note-taking application on my other monitor - switching a video to full-screen causes other monitors to go dark when Displays have separate Spaces is unchecked.

How do I disable dock hopping between my monitors without making all of my screens go dark when I switch one of the windows to the full-screen mode?

If there is no native way to do it, kindly share a 3rd party utility that would allow me to do that.

2

1 Answer 1

1

This jumping behaviour has been annoying me for ages (and with 4 screens it is really a hair pulling feature). A comment in another question dock keeps moving, which I am not allowed to answer to, got me on track for something that seems to work for me.

In terminal use:

defaults write com.apple.dock autohide-delay -float 5.0; killall Dock

And now the dock jumps a lot less. Mind you: it can still jump if you keep your mouse long enough on a different screen. So it is not full proof but it is much better than before.

To revert:

defaults delete com.apple.dock autohide-delay; killall Dock

Original source

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .