3

The camera light on my M2 MacBook Pro is on, and I'm not actively using any app that uses the camera.

If I quit all apps (except Finder), the light stays on. If I then remove camera permission from all apps in Settings, the light stays on. A restart fixes it.

Is there a command I can run to find out what app has the camera open?

3
  • Relevant: apple.stackexchange.com/q/79252/24324 Mar 30, 2023 at 9:27
  • I don't know whether changing the permission while the process is still running would 'kill the camera'. Can you provide a screenshot of the list of camera apps allowed?
    – benwiggy
    Apr 1, 2023 at 8:40
  • No, but it was Safari, Chrome and Tuple from memory. Apr 2, 2023 at 21:21

1 Answer 1

2

I'm not actively using any app that uses the camera.

First thing to do would be to simply quit each app in turn, and see if the camera light goes off, until all apps are quit and only the Finder is running.

If the light is still on while only the Finder is running, then that's a problem. Look at the list of processes that are allowed to access the camera in System Settings > Security & Privacy. If there's nothing out of the ordinary there, and the light is still on, then I'd suggest ensuring that you have a current backup, erasing all user content (System Settings > General > Transfer or Reset), and then restoring your data, but not apps.

7
  • A simple reboot might be worth trying, at least before erasing user content.
    – nohillside
    Mar 30, 2023 at 8:23
  • I did this (quit all applications one by one) and got down to the bare Finder and the light's still on. I want a command which will tell me which app is using the camera because I don't want to go through the hassle of rebuilding the machine. Of course a reboot fixes it. Mar 30, 2023 at 8:27
  • @RobertAtkins Go to Settings, and revoke camera access for all applications registered there.
    – nohillside
    Mar 30, 2023 at 8:28
  • @RobertAtkins That's useful information for the question. What processes are listed in the Security preference pane? A quick Google brings up using lsof | grep "AppleCamera", but I tried that and it doesn't seem to work, so there may not be any obvious pertinent command.
    – benwiggy
    Mar 30, 2023 at 8:57
  • Yes, that lsof invocation hasn't worked for years, apparently. Mar 30, 2023 at 9:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .