During an install of XCode 4.2 for Snow Leopard (this is on a brand new install of Mac OSX that has been updated to the latest OSX version), I'm getting the following error in the /var/log/install.log file.

Failed install preflight: Error Domain=PKInstallErrorDomain Code=102
UserInfo=0x1003c46b0 "The package “OpenGLApps.pkg” is untrusted." Underlying 
Error=(Error Domain=NSOSStatusErrorDomain Code=-2147409654 UserInfo=0x1003b1f10
"The operation couldn’t be completed. CSSMERR_TP_CERT_EXPIRED")

The installer indicates a generic error and suggests to try the install again or contact the vendor.

Based on the entry in install.log, I'm guessing that there may be a way to force the OpenGLApps package to ignore the cert check.

This install was downloaded today from apple's developer website under Other Downloads.

  • 1
    Can Xcode 4.2 even be installed on Snow Leopard? Isn’t Xcode 3.2.6 the latest version for Snow Leopard? Mar 25, 2012 at 8:51
  • Mathias is correct, as far as I know 3.2.6 is the last version of Xcode compatible with Snow Leopard. If you found a way to get Xcode 4.2 working on 10.6 I'd be really interested in hearing about it as it would save me a $30 upgrade :) Mar 25, 2012 at 16:18
  • There are several available 4.x downloads for Snow Leopard, but you have to log into the developer website to get them. Mar 25, 2012 at 20:52

2 Answers 2


Dave, your post and subsequent answer were just what I needed, and very refreshing indeed. I was getting the same error and log output, trying to install Xcode 3.2.6 with iOS 4.3 on OS 10.6.8 (the untrusted package in this case was iPhoneSDKTools.pkg). I had tried a bunch of other things, to no avail.

When I followed your suggestion and checked for updates, it listed one for Safari (including some security-related fixes) plus another for the Application Installer (or something similar) - the description for that mentioned something about fixing problems installing certain apps on 10.6.8! After doing those updates the Xcode install finally worked. I'm pretty sure it was the Application Installer. I didn't have to download a fresh Xcode installer, I just used the one I'd been trying to use all along.

Other posts I'd found recommended reinstalling Snow Leopard, which seemed a bit extreme and didn't answer why it was happening. I think you've hit on the real issue and a nice straightforward easy solution. Thanks. I can now abandon my plans to leap into the Abyss.

  • 1
    I was going to say that this should be a comment, but then I remembered that new users can't comment. Personally, I think this is a stupid policy, meta.stackexchange.com/questions/12119. So thanks for the additional info and here is some rep to get you started. Mar 25, 2012 at 15:54
  • Also, note that there are Xcode 4.x downloads available for Snow Leopard. You have to log into the developer website and search for them. Mar 25, 2012 at 20:55
  • Jeff, thanks for the more in depth details. Marking your response as the answer. Welcome to stack exchange. :) Mar 25, 2012 at 20:57

After updating Safari and other applications, the Xcode installation was able to proceed.

  • 1
    Dave, as Jeff mentioned, it was the update to the application installer that fixed the issue, not the Safari update. Just tested this out on my machine, choose to not update Safari and just updated the installer and the XCode install is now working for me. Mar 25, 2012 at 15:50
  • Excellent. I didn't see that in the list, but it makes a lot more sense. Thanks for pointing that out. Mar 25, 2012 at 20:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .