I have a brand-new 14" MacBook Pro M2 running Ventura 13.2.1. In System Preferences ▹ Displays, I have "Automatically adjust brightness" turned off. I'm not using an external monitor. I set the brightness to full when using the laptop. When the laptop wakes from sleep, the brightness is down to half, not the full brightness I used before it went to sleep. This is 100% reproducible. I don't have to close the lid; simply letting it time out and put the display to sleep makes this happen.

Why is this happening, and how can I make it stop, so that I don't have to keep resetting the brightness up every time I wake the machine from sleep?


1 Answer 1


The relevant setting turns out to concern the behavior when running on battery power. To stop the behavior I was seeing, go to the Displays panel of System Preferences, then click on the Advanced … button at the bottom,

enter image description here

and in the sheet that is shown next, turn off the setting titled "Slightly dim the display on battery":

enter image description here

  • 1
    For Sonoma this setting is in battery.
    – onetwo12
    Commented Oct 9, 2023 at 6:57
  • Thank you SO much!! This was driving me batty on my 2019 16" MacBook Pro running macOS Ventura 13.6.1!! It was always just kind of an irritant... finally this morning I'd had enough, and found your post! Exactly what I was looking for :) Commented Nov 29, 2023 at 13:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .