1

I have an iPhone 12 64GB and the 5GHz personal hotspot stopped working a few months back.

The "Maximize Compatibility" switch doesn't seem to do anything, it always shows up as a 2.4GHz network on my other devices.

I have used it previously on my laptop and Meta Quest 2 and the 5Ghz band was working fine.

After the iOS 16.2 update it stopped working. Any ideas what the problem could be?

1 Answer 1

1

The feature works as described for me. When I enable "Maximize Compatibility" the personal hotspot is 2.4GHz and when I disable it is 5GHz. I am running iOS 16.4 beta with iPhone 14 Pro.

In my testing one thing I noticed is if you had "Maximize Compatibly" enabled and a device is currently connected to the hotspot it will not switch to 5GHz immediately when you disable it. To make sure it switches 5GHz I first disabled Maximize Compatibility then briefly toggled "Allow Others to Join" off and on.

If that is not your problem then it sounds like a bug, and nothing that can be fixed in settings by an end user.

Some options:

  1. Report the issue to Apple at https://www.apple.com/feedback/iphone/
  2. Contact Apple support or visit an Apple Store
  3. Try wiping out your phone and doing a clean install
  4. If you are still on iOS 16.2 try upgrading to 16.3, and when 16.4 comes out try it.

If you are trying to connect both your gaming PC and Meta Quest 2 through the iPhone Personal Hotspot you may have issues with 2.4GHz being too slow for Air Link streaming. Even at 5GHz I would not really recommend using Personal Hotspot and would recommend a dedicated wireless router instead.

1
  • 1
    I tried this and it worked! I turned of my personal hotspot before turning on the wifi on my laptop and now it's showing 5GHz! Thank you so much! Commented Mar 27, 2023 at 10:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .