I ordered this keyboard for my Mac desktop.


As you can see, it has a numpad on the far right, just like my old one. When I enable mouse keys (I like to use the numpad to control the mouse sometimes), it works properly, but it also uses '789uiojkl' as mouse keys, which prevents me from being able to type normally. This wasn't an issue on my other keyboard. Is there any way that I can disable the '789uiojkl' mouse keys but keep the numpad ones?

From what I understand, the '789uiojkl' should only be available for keyboards that don't have mouse keys, but mine does and it enables both of them, which is beyond pointless and extremely annoying.

  • What was the MacOS version and "other keyboard" where you did not have the problem? Apple's info about Mouse Keys says "Note: When Mouse Keys is on, you can’t use the keyboard or a numeric keypad to enter text." support.apple.com/guide/mac-help/… Mar 24 at 12:28
  • @TomGewecke - it's definitely not 'correct' behaviour to steal both the numpad and the right-most qwerty keys. [Owner of nothing but Macs with extended keyboards since System 9.] A Boy - see if you can make it forget, then re-add - see apple.stackexchange.com/q/309036/85275
    – Tetsujin
    Mar 24 at 12:33
  • Just tested on a new M1 iMac, modern bluetooth magic keyboard with Touch ID, with almost no customisation [had to switch the opt-key toggle on to test. Same behaviour, mousekeys affects only the numpad, not qwerty.
    – Tetsujin
    Mar 24 at 12:40
  • @Tetsujin I wonder if the OP's machine is Intel and if that could make a difference with that "silicon" keyboard. Mar 24 at 13:03
  • @TomGewecke - not sure. The same ad does mention further down that the Touch ID version is 'for Apple Silicon'. Reqs for this one: Bluetooth-enabled Mac computer with macOS 10.12.4 or later. The Touch ID reqs: Mac with Apple silicon using macOS 11.4 or later {I have a lot of old wired ones, but only the one 'magic' on the M1 iMac, so not enough options to properly test]
    – Tetsujin
    Mar 24 at 13:18


You must log in to answer this question.

Browse other questions tagged .