1

I've a 2015 MBP, which I've not used for years. I need it and forgot the password. The router was changed, so it's not connected to the internet and apparently I can't update it. The ⌘ Command R shortcut to enter recovery mode seems not to work - I tried both holding before restart, pressing it during restart, pressing it many times, etc. and it doesn't work.

I'm considering taking the hard drive out, buying an encase and trying to reset the password from my current M1 MBP but not sure what's the path to follow here.

What should I do?

10
  • Your M1 Mac wont boot off that drive if you haven't updated. Also, cmd+r must work, maybe your keyboard is broken? Try using an external one
    – X_841
    Mar 23, 2023 at 13:08
  • @X_841 I have a bluetooth magic keyboard (which seems to work on the password input). I tried with this keyboard and the internal keyboard. The internal keyboard has some defects however, the R key seems to be working - not 100% about CMD however, but I tried with both CMD keys and it's unlikely that both are broken, so... anyway, could you please confirm when and how exactly this combination should be pressed? I'll try a few times again.
    – User
    Mar 23, 2023 at 13:12
  • Also adding that yes I was sure that the internal keyboard was activated when I tested it. I turned the magic keyboard off and tested on the input first for those tests.
    – User
    Mar 23, 2023 at 13:13
  • ...and also just tried with the magic keyboard over USB and same issue (not sure that it's using USB however)
    – User
    Mar 23, 2023 at 13:18
  • Cmd-R isn’t going to work if there’s an issue with your recovery partition (which could be the case here). Force Internet recovery with Cmd-Opt-R; you will be given an opportunity to enter the new WiFi passkey.
    – Allan
    Mar 23, 2023 at 13:37

2 Answers 2

1

You've potentially missed some details we might need to assist. Are you following a guide by Apple on things to do when your Mac won't boot or willing to engage support so they can help ask some clarifying / guiding questions - you might have some good options if you could borrow a second Mac as well and avoid having to open yours by using target disk mode.

Some of the questions that support can help with are:

  • What are your goals? Erase / start over - get some files back - try to rejoin it to a network and use it as is?
  • Do you have any sort of backup? Cloud / disk / USB key / other?
  • Did you miss any steps in the diagnosis / attempts to boot?
3
  • Yes, I'm trying to get some files back. I don't have a recent enough backup. I'm holding down the power key 10 secs to turn it off and then CMD+R (pressed at the same time) holding or pressing continuously, also tried CMD+OPT+R and nothing works, it just shows normally the login screen. I've tried with the built in keyboard (defective) and a magic keyboard connected with USB/bluetooth. Target disk mode seems not to work either, holding the T key when turning it on doesn't do anything.
    – User
    Mar 23, 2023 at 14:53
  • When multiple key combinations fail to work, that's usually a USB keyboard / bus issue. Make sure you bring a known good USB keyboard - any PC one should work to the machine to be 100% sure you don't need a repair to get at the drive and data.
    – bmike
    Mar 23, 2023 at 19:40
  • The m1 mac for some reason refuses to recognize the magic keyboard (with bluetooth or usb-with adapter) so can't test it there. I see that characters appear on the password input on the intel but that's it.
    – User
    Mar 24, 2023 at 13:03
1

The 2015 MBP uses Apple's proprietary "12+16-pin" SSD module. You can buy enclosures that fit, mostly from OWC, but they're not as cheap as normal m2 or SATA boxes.

If you enabled FileVault (e.g. disk encryption), then you're not going to get anywhere without a password.

It sounds like there's some hardware problem with the MBP itself. Another option is Target Disk Mode, though that's slightly complicated by the difference in Thunderbolt versions.

1
  • But this would help at least with the recovery mode or potential keyboard issues? I'll also check again about target disk mode. From what I read yesterday I've to keep 'T' pressed on the Intel Mac and similarly to recovery mode, it didn't seem to work.
    – User
    Mar 24, 2023 at 13:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .