Mac Mini M1 (16GB mem, 1 TB ssd) running Ventura 13.2.1 Printer HP Laser jet 100 colorMFP M175nw (Print and Scan functions) Installed printer driver version is 3.0 (automatically retrieved from the servers at Apple)

I am losing the scan function of my HP printer after rebooting or signing out and in again. The scanner icon (far right) on the printer pop-up box is greyed out The printer remains on line and the print function keeps on working.

Switching the printer off and on again does not produce this problem.

I am only able to repair the scan function by deleting the printer ( & drivers I assume) and subsequently re-installing them. The re-installed driver version is exactly the same as before. Launching the printer from the dock and pressing the scanner icon then launches display scanner window with all the available scan options.

Resetting the printing system, when the scanner does not work, does not cure the issue either. Prior the Ventura everything was working just fine with drivers provided by Apple.

Grateful for advice

ps: English is not my native language so apologies for grammar errors.

Additional information in answer to Steve's comment / suggestion below

Tried HP smart from the Apple app store (v 14.3.0). This initially seems to work but the maximum dpi is only 300 which is too low. The scanner is capable of 600 and 1200

Tried HP easy start from the HP site (v 10.4)which gives the same problem as v3.0 from the Apple servers.

In answer to Allan's remarks below:

When you add the printer in system settings, tab printer & scanners the system detects the hardware and automatically finds and installs the correct driver v3.0 (from the apple servers). No admin password is asked.

As for accessibility, there is no such entry whatsoever.

For completion, I have this phenomena on 4 different Mac's

Tried HP Easy Admin which got the scanner working but only at a max of 300 dpi, which is too low

  • 1
    So this started happening when you upgraded to Ventura? That would point to the drivers you have being not fully compatible with macOS Ventura as that is the only thing you have changed. Have you checked HP's website for updated drivers? Mar 21 at 19:52
  • The driver for the scanner and for the printer are two different things, so even though you have one device, you must treat them separately; as if they were two devices, not one. I am thinking the scanner driver is being loaded/unloaded in userland (it works until logout) but there is a permissions problem preventing it from loading again. When you install the drivers are you asked for an admin password? Is there an entry in “Accesibility” for “allowed apps” anywhere in there?
    – Allan
    Mar 22 at 14:24
  • This sounds like an HP driver issue (Apple doesn’t make separate drivers, HP just gives them to Apple). Instead of Easy Smart, try the Easy Admin which allows manual downloading and locally hosting the drivers
    – Allan
    Mar 23 at 14:19


You must log in to answer this question.

Browse other questions tagged .