4

I have a Mac Mini M1 running Ventura. I am using a text editor, but I have tried this in other software, including Notes.

From time to time I try to give Dictation a go, but there are some things I can’t get working. In particular, it doesn’t matter what I try, I can’t get a new paragraph or new line.

According to Commands for dictating text on Mac saying new paragraph or new line should work, but all I get is an extra space on the same line.

I accept that I speak with an Australian accent, but it has no trouble with the rest of the words I dictate, so I don’t think it’s the accent; anyway, the accent isn’t so outlandish.

What is the secret to getting it to work?

1
  • The extra whitespaces get replaced with linebreaks, after I end the dictation. Whilst the dictation feature is still active, only extra whitespaces show – so I also suspected, that the new line command is not working. But for me it does, just in this unexpected way.
    – armel
    Apr 27, 2023 at 21:01

3 Answers 3

2

Using Dictation on macOS, you can enter punctuation like “new line” simply by saying “new line”. Apple has an excellent document listing the available commands Commands for dictating text on Mac.

Following is a list of some common punctuation. The full list is available at the link above. Simply say the command noted to produce the desired punctuation:

Common Punctuation

Command Output
Open Parenthesis (
Close Parenthesis )
New Line (Carriage Return) (⏎) *
New Paragraph (Pilcrow) (¶) *
Colon :
Comma ,
Dash -
Ellipsis
Period/Dot/Full Stop/Point .
Ampersand &
Asterisk *
Pound Sign/Hashtag #
No Space On (next phrase w/o spaces)
No Space Off (next phrase w/ spaces)

If you’re having difficulty

Most of the time I’ve encountered this was with folks with environmental obstructions; usually a quality microphone/headset and a quiet(er) environment helped immensely. Ensuring there’s nothing physically between you and the microphone is also key.

You’re Aussie accent should be no problem as I have had this working with folks from the UK and the Caribbean (very heavy accents both). Though it didn’t didn’t work at all with slang (all-all-yuh) for “all of you.”

Apple has several tips for improving voice recognition. See the Support Document If your Mac doesn’t recognize text and commands you speak.


* The character in parenthetical notation is not output, but the non-printing character is (i.e ‘⏎’ advances the cursor to the next line)

1

The easiest way to get a new line is to say the command (new line), you will know it worked because it just inserted a space. Then terminate dictation(I use pressing Control twice) and the new line is inserted. Then I enable Dictation again and go my merry way.

Same applies new paragraph.

It is not a bug per se, I would say this is how the folks that implemented Dictation for MacOS intended it to work.

Design flaw? I would say so because the solution is not intuitive, and nowhere is it stated that this supposed to be how it works in the Dictation commands page.

0

I'm also experiencing this issue on the latest MacOS Ventura 13.3. New lines only appear as spaces while dictating and are only converted into actual new lines after dictation is finished, either by pressing the 'done' button or waiting for 30 seconds.

It appears that this is just how the Dictation feature was designed, so there's not much we can do about it. Here's the source, which I've highlighted for your convenience: https://support.apple.com/guide/mac-help/use-dictation-mh40584/mac

  1. To insert a punctuation mark or perform simple formatting tasks, do any of the following:
  • Say the name of the punctuation mark, such as “exclamation mark.”
  • Say “new line” (equivalent to pressing the Return key once) or “new paragraph” (equivalent to pressing the Return key twice). The new line or new paragraph appear when you’re done dictating.

I've seen some posts online suggesting that enabling Voice Control could fix this issue. However, I don't want to do that as I find it too intrusive. Your mileage may vary.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .