When I set ACL with the permissions for the folder in File Sharing (System Settings > General > Sharing > File Sharing > info) the same ACL and permissions are set for the folder itself on the file system (ls -ld folder/ or Folder info). Basically, the folder on the file system mirrors the settings from File Sharing. As well, when I set ACL for this folder in File Sharing, the Folder info shows that it is Shared folder. When I switch File Sharing in System Settings on, the Finder shows notification Folder shared with File Sharing when the folder is opened. By changing the ACL in the File Sharing settings I can cut myself off from accessing my home folder, temporarily though.

This behaviour is odd and I think it started when I wanted to disable access to all volumes with File Sharing and stop sharing Macintosh HD along with other shared content via SMB for Administrators. So I have modified defaults /Library/Preferences/SystemConfiguration/com.apple.smb.server and added two keys – VirtualAdminShares and VirtualHomeShares – as described here. It helped me to disable the access to all volumes but the issue described above appeared and it persists even when I reverted the changes and deleted the added keys.

When we tried to enable File Sharing on my colleague’s Mac, nothing on the file system mirrors the changes from the File Sharing settings. No Sharing notifications, no Shared folder in the info of the folder, and the permissions of the folder itself are also not reflecting the changes from File Sharing settings.

My and colleague’s Macs run Ventura, my is Intel based, his is ARM based. Any help would be appreciated.

1 Answer 1


So we found out this behaviour that the ACL and its permissions from SMB are linked to the actual folder is a default behaviour.

Previously, when we tested it on my colleague’s Mac, we were changing SMB permissions of his Public folder from his Home folder. Not SMB permissions of the Home folder itself for which we were checking the permissions and Folder info.

That means described issue is invalid.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .