I regularly work with git on an SMB mounted share on my MacBook. Recently I get this error every time I try to run certain git commands: zsh: bus error git status. The same error happens with log, diff, and show. But other commands like git remote work fine.

From my searches online, this error suggests the memory address is not accessible. I don't have any problems running git on a local folder. And I haven't noticed any other problems with this SMB mount; I can read/write files. The problem only happens with git on SMB.

I tried switching to bash and it has the same issue:

bash-3.2$ git status -v
Bus error: 10

I believe the repo itself is okay because I can run git commands via SSH on the remote server with no issue.

I believe this problem started when I upgraded to Ventura. I'm currently on 13.2.1 with git version 2.37.1 (Apple Git-137.1)

  • On what Mac hardware are you running this?
    – nohillside
    Mar 13 at 8:19
  • 2019 Macbook Pro
    – Elliott
    Mar 13 at 17:36
  • 1
    @Elliott did you ever figure out how to solve it? I'm having the same error (also with git on a SMB valume)
    – Politta
    May 11 at 21:09
  • I'm having the same issue, I don't know to fix that crap.
    – Inkeliz
    Jun 17 at 10:48
  • Does the error also occur with a git command which does not need to access the volume? For instance git --help or git --version. Does git status work on a repo which is not on SMB, for instance on your hard disk? Jul 13 at 7:06

2 Answers 2


I encountered the same error, and it seemed to be linked to using Git through Xcode's Command Line Tools. To resolve the issue, I decided to install Git separately via Homebrew.

Here's what I did:

brew install git

After running this command, I closed and restarted my terminal, which successfully resolved the issue.

The version of Git that was causing the error was git version 2.39.2 (Apple Git-143), but after installing Git through Homebrew, I was upgraded to git version 2.41.0.

So, if you're running into a similar issue, try installing Git via Homebrew and make sure to restart your terminal afterwards.

Moreover, if this doesn't solve the issue, as a temporary workaround, you can also try unmounting and remounting the SMB server. However, bear in mind that this might only provide a temporary relief as the issue may recur. If the issue persists even after using the above method, give this workaround a shot.


I encountered this issue again. This time around, I tried a different approach: deleting the repository's .git directory and reinitializing it with git init. Strangely enough, this seemed to work, but I must confess, I'm still at a loss as to why this error occurs in the first place.

  • I think this "fix" was actually a coincidence. I tried using git 2.41 from homebrew and it has the same problem.
    – Elliott
    Aug 6 at 21:51

I had the same problem with a git repository on SMB (using git version 2.42.0 from Homebrew). Unmounting the SMB share and mounting it again seems to have fixed it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .