I have disabled Secure Boot and removed Activation Lock on my MacBook Pro 2019 to be able to install Ubuntu to my MacBook. After a time using Ubuntu, now I want to reinstall MacOS but I can not. I have tried to create a USB with both Mac Ventura and Monterey installer (that my MacBook previously supported and worked well) I have tried to:

  • Startup from Mac Recovery option using Cmd+Opt+R, Cmd+Opt+Shift+R, My MacBook restart once, indicates that it is downloading recovery from Internet twice then got failed with error -1008F, in both startup ways.
  • Started the macOS installer from USB, and tried both Ventura and Monterey, but my MacBook keeps restarting.
  • Reset NVRAM and SMC

But they do not help at all.

I guess it failed because I deleted the internal SSD NVME partition table APFS, then reinstall it with the Linux partition table.

I tried to boot into Ubuntu from USB, to re-create the GPT partition table for the internal SSD. But it does not help, either.

I tried to create an external SSD with an APFS partition and then clone it to an internal SSD using Clonezilla but Clonezilla can not create a partition table on an internal SSD.

  • 1
    -1108F is a connectivity error. How, specifically, did you make the USBs? As far as I'm aware, Ubuntu doesn't understand APFS.
    – Tetsujin
    Mar 12 at 11:15
  • You must have used a different Mac to create the USB installers. Have you tested to see if the installers will boot on the Mac used to create them? Ubuntu includes gdisk which is capable of creating APFS partitions. Creating the partition is not the same as formatting to create a APFS container inside the APFS partition. Mar 12 at 11:40
  • @Tetsujin The error code is 1008F, not 1108F. I used other Macs to make the USBs. However, all Macs I used to make USBs are M1 Mac. Could that be a problem? Mar 12 at 12:50
  • @DavidAnderson Yes. I have used other Macs to make the USBs. I have a MacMini 2020 and a MacBook Pro 14 inch 2021. Both of them are Apple Silicon (M1 and M1 Pro). Mar 12 at 12:52
  • And also, the USBs I created work well with my other Mac, except the Pro 2019 version one Mar 12 at 12:55

1 Answer 1


Finally, I have fixed my Macbook thank to this post: Macbook Air 2019 will not boot from USB or complete Internet Recovery, Exhausted options

My Mac's firmware was corrupted. I used another Mac to reset it in DFU mode.

Read more at Apple's Documentation: https://support.apple.com/en-vn/guide/apple-configurator-mac/apdd5f3c75ad/mac

  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Allan
    Mar 14 at 19:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .