5

As per the title, on macOS Ventura, Spotlight works flawlessly ... except that Safari, nestled in Applications as always, is missing. "saf ..." "safari" "safari.app" — none return the application in search.

I have tried everything I can think of to resolve this — focusing on ways to rebuild the index (the Spotlight Privacy trick, Terminal, Safe Mode, Onyx) and/or finding and deleting a spotlight.plist file.

This only started happening a couple of days ago. I just installed Safari Technology Preview and it shows up just fine in Spotlight.

At the back of my mind my suspicion is it is connected to restricting access to Safari on my iPad (same iCloud account) — but I have since undone this and still the problem persists.

Is there a way to reset things on macOS Ventura with the sealed system volume snapshot and recent changes to the OS?

1
  • Could be because /Applications/Safari.app is a symlink to ../System/Cryptexes/App/System/Applications/Safari.app at least in macOS 14 Sonoma
    – cachius
    Dec 18, 2023 at 11:56

2 Answers 2

7

That's because Safari.app now is on the Preboot volume rather than the / volume, and you probably have disabled indexing on the Preboot volume. To confirm that, run

mdutil -sa

and check the status of the Preboot volume. If indexing is indeed disabled, you can turn it on with the command

sudo mdutil -i on /System/Volumes/Preboot
2
  • 1
    You did it. Thanks so much. I don't know how or why such indexing was disabled. Mar 30, 2023 at 7:24
  • 1
    Do you know why/how this would have been disabled? The same thing happened to me, and I have no idea how it happened.
    – Brian
    Nov 29, 2023 at 1:57
-2

I went through a similar exercise a while back but was eventually able to resolve it. Here are my solutions; not sure if you have tried any of these yet.

A. Disable / re-enable Spotlight Privacy

(it seems you may have tried this already) Add Safari to the Privacy tab in Spotlight Preferences and then remove it again. This can help rebuild the index for Safari and allow it to show up in Spotlight search results.

  • Open System Settings and click Siri&Spotlight.
  • Click on the Privacy tab or Spotlight Privacy button.
  • Click the "+" button at the bottom of the list of excluded locations.
  • Navigate to the root level, and select the "Applications" folder.
  • Close System Settings
  • Open System Settings and select Siri&Spotlight again.
  • Click on the Privacy tab or Spotlight Privacy button.
  • Select the /Applications folder from the list of excluded locations and click the "-" button to remove it.
  • Close System Settings and try searching for Safari in Spotlight again.

B. Resetting the Launch Services database

To restore Safari's indexing in Spotlight.

  • Open Terminal.
  • Enter: /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -seed.
  • Wait for the command to complete (could take a few minutes).
  • Restart.
  • Try searching for Safari again.

C. mdutil

  • Open Terminal.
  • Enter: sudo mdutil -i off /
  • Enter your admin password.
  • Enter: sudo rm -rf /.Spotlight-V100
  • Enter: sudo mdutil -i on /
  • Wait for reindexing process to complete (could take a few minutes).
  • Restart Mac and try searching for Safari again.

D. Resetting the permissions on your Applications folder

  • Open Terminal.
  • Enter: sudo chown -R root:wheel /Applications
  • Enter your admin password when prompted.
  • Wait for the command to complete.
  • Restart and try searching again.

E. Rebuilding Launch Services

It contains information about all installed applications on your Mac.

  • Go to Terminal.
  • Enter: /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user
  • Wait for the command to complete (again, could take a few minutes).
  • Restart.
  • Try search again.

F. Resetting the Spotlight index on your Mac

  • Terminal
  • Enter: sudo mdutil -a -i off
  • Enter admin password.
  • Wait for command to complete.
  • sudo rm -rf /Volumes/*/.Spotlight-V100/ Note, that this command will delete the Spotlight index files for all connected volumes. If you have multiple volumes connected to your Mac, you may need to repeat this step for each one.
  • sudo mdutil -a -i on
  • Wait for the command to complete.
  • Restart.
  • Spotlight will rebuild the index for all connected volumes, which could take some time. Once indexing is complete, try searching again.
3
  • Thanks so much. When I reset the permissions, the only result was "chown: /Applications/Safari.app: Operation not permitted" — so I guess that explains ... something. If you know how I rectify this, then please let me know. Mar 8, 2023 at 14:59
  • 1
    You could precede it with sudo, so sudo chown -R [owner] /Applications/Safari.app. You need to be in the sudoers file to do that. Mar 8, 2023 at 22:58
  • There is no /.Spotlight-V100 in Ventura, nor is it possible to change the permissions on Safari.app. Where did you get this proposals from?
    – nohillside
    Jun 12, 2023 at 15:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .