1

Pressing ⌘ Command⇧ Shift4 then pressing space then clicking on a floating window takes a screenshot of that floating window with the dropshadow included.

For some reason, mine now have white backgrounds...

How can I make it use a transparent background instead?

% defaults read com.apple.screencapture
{
    "last-analytics-stamp" = "699383078.004545";
    "last-messagetrace-stamp" = "607952564.008211";
    "last-selection" =     {
        Height = 597;
        Width = 1138;
        X = 336;
        Y = 220;
    };
    "last-selection-display" = 0;
    location = "~/Downloads";
    "location-last" = "~/Downloads";
    "show-thumbnail" = 0;
    showsCursor = 1;
    style = selection;
    target = file;
    video = 1;
}
4
  • 1
    What format are you saving the screenshots as?
    – benwiggy
    Mar 8, 2023 at 8:07
  • @benwiggy PNG. I don't see any way to change it anyway (in cmd-shift-5 options)
    – minseong
    Mar 8, 2023 at 13:33
  • It can be changed, and some formats don't allow transparency. So it's not that. Can you add the results of this Terminal command to your question: defaults read com.apple.screencapture Also what Mac model is this?
    – benwiggy
    Mar 8, 2023 at 14:06
  • @benwiggy there's nothing in defaults read com.apple.screencapture that seems to be about background color. Macbook pro 2015. Until recently, these screenshots had always had transparent background.
    – minseong
    Mar 8, 2023 at 14:11

1 Answer 1

2

type in terminal:

defaults write com.apple.screencapture type png

This rewrites the value of the key type from the default jpg to png. To revert just do the above command but replace with jpg instead.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .