3

I am using a British PC ISO version of the HP Omen Encoder keyboard with my MacBook Pro (Ventura v13.0), and I can't seem to correctly configure my keyboard. My keyboard looks like so:

A UK ISO PC keyboard layout

But I have a very similar issue as described here, in that the Mac keyboard settings refuse to see the pipe key left of the 'Z', and when I press this backslash button, it produces a '`' (grave key), whilst the top-left grave key produces a backslash.

The linked prior question suggests either re-running the Keyboard assistant and ensuring it gets ISO and then setting source to British - PC, but this doesn't change anything, or using Karabiner to just swap the non-us backslash key with the grave key, but for some reason this isn't working. Interestingly, Karabiner's event viewer says {"key_code" : "grave_accent_and_tilde"} when I press on the grave key, but it inputs a backslash into the input test field as it does so (and vice versa when I press the backslash).

Does anyone have any insights into how to either get my MacBook to recognise/swap my backslash key, or why Karabiner isn't working with my HP Omen encoder?

Thanks

3
  • 1
    With the Input Source open, try turning the keyboard off & on again. No, really. Mine is the answer you linked & after all these years, that's still what works. [This with different Mac & keyboard, though the Mac is still on Mojave.]
    – Tetsujin
    Commented Mar 7, 2023 at 19:14
  • If you rerun keyboard setup, and it says to press the key next to Z, instead press the key under escape. Commented Aug 29, 2023 at 13:28
  • Did you ever get to the bottom of this? I am having the same issue and everything I tried doesn't work. It's diving me mad!
    – Organic
    Commented Sep 11, 2023 at 14:05

1 Answer 1

2

In Karabiner-Elements, under "Virtual Keyboards", try setting "Country code: 0" to ISO

Karabiner-element screenshot

Once that's done, System Settings > Keyboards > Input Sources should see the British - PC input as ISO (the enter key is an upside-down L, and the ` and \ are in the right place)

ISO layout in system settings input source

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .