0

On my iPhone in Settings > Phone > Calls on Other Devices, my MacBook appears twice. How do I get rid of the second entry?

I've tried logging out and back into iCloud, but it doesn't do the trick. I suspect it has to do with some "lost" key in iCloud Keychain. It only appears twice there, so I'm assuming FaceTime, and not in the iCloud list of devices as well.

Any idea how can I remove that extra entry?

6
  • I once had this issue long ago, but I can’t recall what I did exactly to fix. But, start with looking at your devices in iCloud; you might have more than one entry for your MacBook.
    – Allan
    Commented Mar 4, 2023 at 18:34
  • @Allan right, in iCloud, only one devices show. However, I suspect in keychain there must be two entries.
    – Dan
    Commented Mar 4, 2023 at 18:44
  • Keychain has nothing to do with Continuity or more specifically, Handoff.
    – Allan
    Commented Mar 4, 2023 at 18:50
  • Out of curiosity, were these two devices connected to a different WiFi with either device having network privacy enabled?
    – Allan
    Commented Mar 4, 2023 at 19:09
  • Possibly, it's the same MacBook, just shows up twice, I think I re-installed macOS without first signing out of iCloud or something.
    – Dan
    Commented Mar 4, 2023 at 19:23

1 Answer 1

0

Change your Apple account password, and when asked, log out of all devices, this will force a log out of whatever "ghost devices" show up in "Calls on Other Devices" list.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .