1

Running Big Sur, v11.7.4, fully up to date, on a MacBook Air, Early 2014, as a Standard user (with known Admin credentials).

I did recently install an update to Big Sur maybe a few days ago, but as I haven't recently installed any new apps, I can't be sure when this problem started or if it has anything to do with the update.

The Problem Begins

I was trying to transfer some files to an Android phone so I launched the app Android File Transfer which was already installed on my computer. The app launched immediately but it wasn't seeing my phone. I hadn't used Android File Transfer in over a year, or more, so I thought I'd rule out an app issue by downloading the latest version of and updating the current version. That took me all of two minutes. I overwrote the current version with the new download and tried to launch it... and it just started bouncing in the dock... forever.

What's even weirder is that after double-checking, I realized that the "new" version I installed was the same as the already-installed version. I guess Android File Transfer hasn't updated in a while.

But why was it starting fine before and now it won't start if it is the exact same app and version?

I tried Force Closing and relaunching, I tried restarting the computer and relaunching, and I tried logging in directly as the Admin user, I tried completely uninstalling (Move to Trash) and then reinstalling the app: the app just won't start.

I figured out another way to get done what I needed with my Android phone, so I left that aside since everything else was working fine, and I don't really use Android File Transfer much.

The Problem Continues

Then today, I needed to consolidate two similar folders. I pulled up the already-installed app Beyond Compare. It opened immediately without any problems.

The app launched immediately without any problems, but this is also an app that I again hadn't used in a while, so again I decided to check for updates before continuing. It turns out I was on v4.3.7 build 25118 and v4.4.6 build 27371 was available on the website. I downloaded it from the website, extracted it, and then overwrote the existing install in the Applications folder...

...and now the app won't start. It's the exact same symptoms as above. It bounces forever in the Dock and never stops. I tried overwriting it again, I tried logging in as the admin user, I tried uninstalling (Move to Trash) and then reinstalling the app, and I even tried rolling back to the original version which started up just fine (v4.3.7). Nothing works: the app never starts, not even the older version which had just launched with no problems minutes before.

Help

What the hell is going on and how can I go about troubleshooting/fixing this?

I would try with updating another app, but now I'm a bit hesitant. So far both these apps are apps I rarely use. I don’t want to compromise an application I use daily.

Update

Edit 1:

So I experimented with another program I have installed: IINA.

As I also have VideoLAN installed, I can get by if something goes wrong with IINA (which is also another great video player).

I currently have IINA v1.3.1 installed, and it launches and works wonderfully. As the IINA website states, it requires macOS version 10.11 or higher to run, so there shouldn't be any problem with it running on Big Sur (11.7).

I re-downloaded the DMG file for IINA v1.3.1 from their website and copied the app into my Applications directory, overwriting the current install.

As predicted, I am getting the exact same behavior now. The app icon appears in the Dock, starts bouncing forever, and never successfully launches (whereas before it would launch quickly and without issue).

Something is going wrong with my macOS when it writes new apps to the Applications directory. How do I figure out this problem?

Edit 2:

The problem is definitely related to the specific user profile. I created a brand new test profile, and I was able to launch all of the problematic programs with no problems.

Something is happening on my main Standard user profile only when programs are installed (copied to the Applications folder) or updated (copied to and overwriting the existing app in the Applications folder).

But that same new program or overwritten program will work just fine in the new user profile.

What gives? What is unique to the user profile related to apps that could be causing this?

7
  • What’s a “Standard User with known Admin credentials”? You’re either a Standard user or an Admin. Also, did you confirm App compatibility requirements? Are you certain they work with Big Sur?
    – Allan
    Mar 2, 2023 at 22:31
  • What happens if you restore the old version from Time Machine?
    – Barmar
    Mar 2, 2023 at 22:42
  • @Allan That means for daily use I login as a Standard User. But I also know the Admin User credentials which I use to install apps. And, if necessary I can login directly to the Admin account, which is one of the troubleshooting steps I performed.
    – Daniel
    Mar 3, 2023 at 9:14
  • @Allan I would be shocked if Android File Transfer is not compatible with Big Sur, as it is the official file transfer program from Google for all Android phones. Not updating their program to support new MacOS versions would be as nonsensical as Apple not supporting iPhones in Windows past Windows 8. Furthermore, it doesn't make sense that it launched without any problems under Big Sur and then doesn't launch after I reinstall the same version. Anyway, just to satisfy you I doubled-checked their page which says it supports MacOS 10.7 and higher.
    – Daniel
    Mar 3, 2023 at 9:18
  • @Allan It's the same story for Beyond Compare, which is one of the most popular folder comparison utilities across multiple OSs. Furthermore, it doesn't make sense that v4.3.7 would work for Big Sur but v4.4.6 would not. It makes even less sense that rolling back to v4.3.7 wouldn't work. Anyway, just to be sure again, I checked their page which says v4 is compatible with macOS 10.11 and up. Given the same symptoms with two recently installed apps, this seems like a system problem, not an app problem.
    – Daniel
    Mar 3, 2023 at 9:23

1 Answer 1

2

I figured out the problem.

After a recent macOS update, I started getting an alert that a program, Videostream, would "damage my computer". After researching the error, I found that it was a false positive and that the company behind Videostream was working on a patch to fix the issue. I didn't want to uninstall the app, so I just ignored the warning window.

Why not just accept the warning and move on? Well, for some reason macOS is very persistent about this warning. So, even if I click OK, the warning window just pops up again in the center of the screen endlessly, which is extremely annoying and makes it nearly impossible to work.

So, I just dragged the warning window to the corner of the screen and ignored it.

This has been the cause of all my problems.

When I would download a new application, or download a new version of an application, or indeed even download the same version of the app and overwrite it in the Applications folder, it was resetting the flag that tells macOS that the app was downloaded from the Internet.

Do you see where this is going? Maybe not, because it seems a kind of stupid design.

Basically, when I was launching these newly installed/updated/overwritten apps, macOS was wanting to launch a window warning me that

[App] is an app downloaded from the Internet. Are you sure you want to open it?

I then would need to click Open to confirm that I did indeed want to open the "new" app despite it being from the Internet.

But for some stupid design reason, the "Videostream will damage your computer" window was suppressing/blocking/queueing the "[App] is an app downloaded from the Internet" window.

I guess Finder can't display multiple advisory windows at once. It can only display them in a queued order.

Bottomline: the solution was simply that I needed to click OK on the Videostream warning window after launching the "new" app, so that the downloaded app warning window could appear, so that I could click Open on that window, so that the "new" app could continue with its launching process.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .