6

I have the system pref "Automatically illuminate the keyboard in low light" disabled. However, when I wake the computer from sleep and the login prompt appears, the keyboard backlight turns on. Despite the fact that I didn't ask for this, it's actually somewhat useful, so I don't object to that. But, once I log in, the keyboard backlight stays on. AND, to make matters worse, the machine seems to "think" that the backlight is off, because pushing the backlight dimming button (the one shared with F5) doesn't dim the keyboard backlight. Instead, I have to first increase the backlight, then decrease it, in order to disable it.

So, I'm looking for a way either to: 1. ensure that the auto-enabled keyboard backlight self-disables upon login, or 2. completely, 100%, totally disable any auto-enabling of the keyboard backlight (an acceptable alternative to 1, since I don't really need it auto-enabling at login).

Note: an unacceptable solution is one that completely disables the keyboard backlight. I need to be able to invoke it manually when desired.

4

Lab Tick is a shareware menu item that gives you complete control over the keyboard backlight. You can set the level of illumination by hand, and electively disable automatic adjustments made by the OS.

enter image description here

  • Slightly odd behavior in that it (I think it) seemed to make my keyboard flicker when I logged in from sleep, until I did the same increase-decrease backlight trick. For some reason Lion seems INTENT on turning my **** backlight on whenever I log in. :( – Philip Mar 25 '12 at 1:00
  • Behavior repeated. Your software seems to be a good idea, but there seems to be some sort of bug or problem ("feature"?) in my install of Lion. Thanks anyway. – Philip Mar 26 '12 at 2:44
  • Works fine here. Don't know what to tell you. – jaberg Mar 26 '12 at 19:50
  • It was a good thought; I think I'll need to wait until someone with a similar problem finds an actual workaround / finds out how to dig deep and disallow the system itself from turning the keyboard-backlight on without direct instruction from the turn-keyboard-backlight-on button :) – Philip Mar 27 '12 at 4:00
  • Maybe if more people can confirm that this worked for them, I'll accept the answer. Since it didn't work for me I have no basis of judging. – Philip Aug 10 '12 at 13:10
1

You can try reset SMC to fix the bug. Shut down the computer,then press option+control+shift+Power for several seconds and then boot it.

  • Tried it, but no dice. Thanks though. – Philip Apr 3 '12 at 0:25
0

I had this exact problem you described on my MacBook Pro with macOS Sierra. What I did to solve it was:

  1. Open Keyboard preferences: Apple Logo > System Preferences > Keyboard
  2. Check and uncheck the top 3 options ("Adjust keyboard bright in low light", "Turn keyboard backlight off after X of inactivity", and "Show keyboard and emoji viewers in menu bar". I just messed around with them to see what they do.
  3. Close it out.
  4. Re-open Keyboard preferences: Apple Logo > System Preferences > Keyboard
  5. Make sure "Adjust keyboard brightness in low light" is unchecked.
  6. Close it out.
  7. Reboot.

I'm not sure if all these steps are necessary since I cannot replicate the initial problem anymore, but I found the reboot to be necessary. Good luck.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .