1

I use iTerm2 (version 3.50beta10) on my Mac (macOS 13.2.1). Whenever I paste a right single quotation mark (U+2018) aka (’) into a terminal window, it is replaced by an apostrophe (‘) (U+0027).

Can I disable that somehow?

I am pasting using ⌘ Command V.

(I am aware I could use ⌥ Option ⌘ CommandV for "Advanced Paste" to open a dialog and then ⌘ Command ⏎ Return to paste my test, but I don't want more keys and more steps. I want it to paste what I copied.)

6
  • 1
    Is this happening in Terminal as well? What about other Apps like TextEdit?
    – Allan
    Mar 1, 2023 at 1:33
  • Not in Terminal. Not in other apps. Mar 1, 2023 at 8:32
  • 1
    So, we’ve narrowed it down to iTerm. Look in iTerm Preferences in the keyboard tab and see if you have any replacements, shortcuts, etc. Side question… why are you running a beta of iTerm rather than a stable release?
    – Allan
    Mar 1, 2023 at 13:36
  • Sadly, I can't find anything in the preferences. It's a long-standing annoyance, so I don't think it's related to this beta. If it's there (and there are approx 1M options) it's not named or placed obviously. Mar 1, 2023 at 14:39
  • When you open a new window, are you using the default shell or do you have a custom command? It might also be helpful to query the folks at iTerm - let them know it’s only happening in their app. One more Q….are you using OMZ by any chance?
    – Allan
    Mar 1, 2023 at 14:56

1 Answer 1

1

You could try using an app called Keyboard Maestro.

This can allow you to set macros that can do what you're wanting.

E.g. - you could set up a macro like (only in application iTerm2) when I paste " RIGHT SINGLE QUOTATION MARK (U+2018) aka ’ ", backspace one character and type "RIGHT SINGLE QUOTATION MARK (U+2018) aka ’".

Not the perfect solution but an easy workaround.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .