1

Somewhat recently I have been having issues with Netflix.com while using my MacBook Pro (15" 2018). I currently have macOS Monterey 12.6.3 with Safari 16.3. The problem has been happening for over a month I think.

I've also just noticed that despite visiting https://netflix.com, there is no lock icon next to the URL in the address bar unlike all of my other tabs for other https sites I'm currently on.

The only Safari Extension I have installed is AdGuard and the problem exists whether the extension is enabled or not. Netflix.com is the only site I've seen this problem with.

If I visit Netflix.com using my iPhone 13 Pro with iOS 16.3 while on the same Wi-Fi network as my MacBook Pro, all images appear just fine and the lock icon appears next to the URL.

If I select "Show Page Source" and look in the console I see a whole bunch of errors like the following:

[Error] [Report Only] Refused to load http://occ-0-114-3419.1.nflxso.net/dnm/api/v6/<long string of letters and numbers>.avif?r=229 because it does not appear in the img-src directive of the Content Security Policy.

I also see a bunch of warnings similar to the following:

[Warning] The page at https://www.netflix.com/browse was allowed to display insecure content from http://occ-0-114-3419.1.nflxso.net/dnm/api/v6/<long string of letters and numbers>.avif?r=229. (browse, line 6)

I've restarted my Mac, restarted Safari, used the Developer menu to clear caches. Nothing I've tried is working.

Does anyone know how to resolve these two issues (get images to appear, get lock icon to appear)?

If any additional information is needed, please ask.

7
  • That8s the DRM from Netflix. Safari is supposed to be able to decode this video. Try another browser like Firefox or Edge.
    – Allan
    Commented Feb 28, 2023 at 3:59
  • @Allan I've been using Safari to view Netflix for many years. This problem just started a month ago and only on my Mac, not my iPhone. And I'm not talking about any video. I'm talking about the basic browse page where it shows thumbnails of all of the shows in different categories.
    – HangarRash
    Commented Feb 28, 2023 at 4:07
  • Did you try a different browser? It’s still a DRM issue based on the errors - Safari could have received an update and it broke DRM.
    – Allan
    Commented Mar 2, 2023 at 18:07
  • @Allan Netflix works just fine with Firefox on my Mac, even with lots of the security features turned on full. So my question still stands with regard to getting this resolved with Safari. I don't believe this issue is affecting all users of Safari 16.3 while trying to access netflix.com because any attempt to research this issue results in no other mention specific to Safari and Netflix.
    – HangarRash
    Commented Mar 2, 2023 at 18:27
  • Not finding positive search results ≠ problem not existing. You’ve successfully narrowed it down to Safari and not the OS (it’s not system wide). Try turning of any Safari extensions (if applicable).
    – Allan
    Commented Mar 2, 2023 at 18:36

1 Answer 1

3

While not the ideal solution, I was able to get this working by updating macOS from 12.6.3 to 13.2.1 (the latest as of this writing).

Oddly, Safari is still at version 16.3 after the update so I don't know why this fixed the issue. I didn't get a good look at the build number under macOS 12.6.3 so maybe this version of Safari 16.3 is a slightly different build than the Safari 16.3 from macOS 12.6.3.

4
  • It is likely not Safari, but the de-encryption mechanism Safari uses (calls) to show protected content.
    – Allan
    Commented Mar 2, 2023 at 20:30
  • Could've also been some cookies maybe. Did you delete them as well, while you were on Monterey? Did you also try a different browser under Monterey? Commented Mar 5, 2023 at 6:26
  • @AlexIxeras I actually purged all website data in Safari for netflix.com while still on Monterey and it had no effect. As mentioned in the comments below the question I did try Firefox under Monterey and it worked just fine.
    – HangarRash
    Commented Mar 5, 2023 at 6:34
  • @HangarRash Ah, yes, saw the Firefox comment just now. It's weird. Maybe the only other option would've then be to try and re-install Safari. But anyway, you "solved" it and I think Ventura is a much nicer system too. Commented Mar 5, 2023 at 7:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .