MBP 2018 15 10.13.6 (running this system to use some older software)

About 5 days ago this Mac started producing serious sound errors with any wired output I have available currently (internal speakers or 2 different wired headphones). It does not happen on bluetooth.

If I play a file with sound locally (QT/iTunes/VLC – doesn't matter) or say browse to youtube and play a video there everything is fine, up until I get to the 50 minute mark.

And then all hell breaks loose. Buzzing, clicking every 3-5 seconds, sometimes accompanied by a disturbing warping of sound which is hard to describe but maybe like an echo or modulation effect.

Closing the file if local, or the browser tab and restarting the media offers a temporary fix for another 50 minutes.

This particular issue appeared about 5 days ago, after I installed GarageBand 10.3.4. At that time I also moved a couple of things I use regularly to startup items (Macs Fan Control and Tiny Alarm).

Naturally I strongly suspected the GarageBand install was the culprit, that it had installed some new sound drivers or changed some sound preferences somewhere. The installer for GB (list files) doesn't seem to indicate this though. It has put some things in /Libary/Audio/Apple Loops. Everything else appears to be in Applications or my home folder.

I should point out Garageband does not need to have been launched for this sound problem to appear.

What I've tried so far:

NVRAM reset: doesn't work

The 2 kinds of SMC reset: do not work

Trashing com.apple.audio.SystemSettings.plist and com.apple.audio.DeviceSettings.plist: doesn't work

sudo launchctl kickstart -kp system/com.apple.audio.coreaudiod: It's not clear whether this has any more of a significant effect than stopping whatever media is playing, closing it and reopening it and playing (Or starting a new window/tab with youtube). So doesn't work basically.

Tried deleting various system caches with Onyx and restarting. Did not work.

Opening Audio MIDI set up and playing around with whatever settings are available. Did not work

Booting into a virtually virgin user account: Problem is the same there.

Disabling/removing Macs Fan Control from entire system, not starting Tiny Alarm. Did not work.

Safe mode: safe mode has no audio so I can't do much there, although assume sound drivers could be loaded manually.

Console logs are not particularly informative, if I filter for audio and wait for the sound to go bad, there isn't anything obvious, anything at all. No red dots. 1 yellow dot for Quicktime I noticed.

So far I haven't tried:

Booting into recovery and running disk utility/first aid. (Disk utility when booted into the system reports no errors). I haven't done this yet because I want to do a full back up first, and that takes a long time.

Booting into an entirely different system. I guess I could try that. I have a backup done before the sound went bad I could try and see if the sound problem exists there.

But if anyone has any other ideas I would love to hear them because I'm running out of them.

  • Two troubleshooting steps to report back: Create (or login to) another user account and see if the problem exists. What happens if you temporarily disable Macs Fan Control and Tiny Alarm?
    – IconDaemon
    Feb 25 at 22:18
  • Thanks for the comment IconDaemon. I did actually boot into a virtually virgin test account that I had set up a while back. And as reported, the problem persists there too. Macs Fan Control and Tiny Alarm: I have used them trouble free for the last 2 years, although I noticed a slight change when I moved MFC to login items, it no longer asked for permissions anymore. I should say I don't actually change the fan speed, I just leave it in monitor mode to keep an eye on Temps. But I will completely remove them and see if there's a change and get back on this point. Thanks Feb 26 at 22:44
  • Ok, so can now confirm total removal of Macs Fan Control and not running Tiny Alarm with reboot into clean user account has no effect on the problem. Mar 1 at 2:21
  • I’m intrigued by this. You say it’s always around the 50 min mark audio breaks down? Do this: boot into Safe Mode. That will prevent any 3rd party apps or drivers from loading. Play a long video and time it. Make not of how long it takes for things to break. Close the media, reopen and time it again, do this a few times. Let’s get some sample data to see if the times stay consistent or they change over a period,
    – Allan
    Mar 1 at 13:45
  • Thanks Allan for the input. I'm not sure what I'm trying. Safe Mode doesn't appear to have audio at all. I'm not even sure if it will launch some apps. Do you suggest I try to manually load audio drivers ? Or attempt to play something and grab whatever appears in the logs in console? From my experience so far it's very close to 50 minutes. It might be say 50 minutes 5 seconds if I waited for it, but it's very close to 50 minutes. And never under. Sometimes there might be one or two irregular audio pops and clicks before, but the complete meltdown happens at 50. Mar 5 at 7:41


You must log in to answer this question.

Browse other questions tagged .